summaryrefslogtreecommitdiffstats
path: root/drivers/zorro/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/zorro/Makefile')
-rw-r--r--drivers/zorro/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/drivers/zorro/Makefile b/drivers/zorro/Makefile
new file mode 100644
index 000000000..91ba82e63
--- /dev/null
+++ b/drivers/zorro/Makefile
@@ -0,0 +1,23 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for the Zorro bus specific drivers.
+#
+
+obj-$(CONFIG_ZORRO) += zorro.o zorro-driver.o zorro-sysfs.o
+obj-$(CONFIG_PROC_FS) += proc.o
+obj-$(CONFIG_ZORRO_NAMES) += names.o
+
+hostprogs := gen-devlist
+
+# Files generated that shall be removed upon make clean
+clean-files := devlist.h
+
+# Dependencies on generated files need to be listed explicitly
+$(obj)/names.o: $(obj)/devlist.h
+
+# And that's how to generate them
+quiet_cmd_devlist = DEVLIST $@
+ cmd_devlist = ( cd $(obj); ./gen-devlist ) < $<
+$(obj)/devlist.h: $(src)/zorro.ids $(obj)/gen-devlist
+ $(call cmd,devlist)
+