summaryrefslogtreecommitdiffstats
path: root/fs/hostfs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'fs/hostfs/Makefile')
-rw-r--r--fs/hostfs/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/fs/hostfs/Makefile b/fs/hostfs/Makefile
new file mode 100644
index 0000000000..16be592e80
--- /dev/null
+++ b/fs/hostfs/Makefile
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2000 Jeff Dike (jdike@karaya.com)
+# Licensed under the GPL
+#
+
+hostfs-objs := hostfs_kern.o
+
+hostfs-builtin-$(CONFIG_HOSTFS) += hostfs_user.o hostfs_user_exp.o
+
+obj-y := $(hostfs-builtin-y) $(hostfs-builtin-m)
+obj-$(CONFIG_HOSTFS) += hostfs.o
+
+include $(srctree)/arch/um/scripts/Makefile.rules