summaryrefslogtreecommitdiffstats
path: root/net/ceph/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/ceph/Makefile')
-rw-r--r--net/ceph/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/net/ceph/Makefile b/net/ceph/Makefile
new file mode 100644
index 000000000..8802a0c01
--- /dev/null
+++ b/net/ceph/Makefile
@@ -0,0 +1,18 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for CEPH filesystem.
+#
+obj-$(CONFIG_CEPH_LIB) += libceph.o
+
+libceph-y := ceph_common.o messenger.o msgpool.o buffer.o pagelist.o \
+ mon_client.o decode.o \
+ cls_lock_client.o \
+ osd_client.o osdmap.o crush/crush.o crush/mapper.o crush/hash.o \
+ striper.o \
+ debugfs.o \
+ auth.o auth_none.o \
+ crypto.o armor.o \
+ auth_x.o \
+ ceph_strings.o ceph_hash.o \
+ pagevec.o snapshot.o string_table.o \
+ messenger_v1.o messenger_v2.o