summaryrefslogtreecommitdiffstats
path: root/net/handshake/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/handshake/Makefile')
-rw-r--r--net/handshake/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/net/handshake/Makefile b/net/handshake/Makefile
new file mode 100644
index 000000000..ef4d9a211
--- /dev/null
+++ b/net/handshake/Makefile
@@ -0,0 +1,13 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Makefile for the Generic HANDSHAKE service
+#
+# Author: Chuck Lever <chuck.lever@oracle.com>
+#
+# Copyright (c) 2023, Oracle and/or its affiliates.
+#
+
+obj-y += handshake.o
+handshake-y := alert.o genl.o netlink.o request.o tlshd.o trace.o
+
+obj-$(CONFIG_NET_HANDSHAKE_KUNIT_TEST) += handshake-test.o