summaryrefslogtreecommitdiffstats
path: root/sound/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sound/Makefile')
-rw-r--r--sound/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/sound/Makefile b/sound/Makefile
new file mode 100644
index 0000000000..04ef04b116
--- /dev/null
+++ b/sound/Makefile
@@ -0,0 +1,20 @@
+# SPDX-License-Identifier: GPL-2.0
+# Makefile for the Linux sound card driver
+#
+
+obj-$(CONFIG_SOUND) += soundcore.o
+obj-$(CONFIG_DMASOUND) += oss/dmasound/
+obj-$(CONFIG_SND) += core/ i2c/ drivers/ isa/ pci/ ppc/ arm/ sh/ synth/ usb/ \
+ firewire/ sparc/ spi/ parisc/ pcmcia/ mips/ soc/ atmel/ hda/ x86/ xen/ \
+ virtio/
+obj-$(CONFIG_SND_AOA) += aoa/
+
+# This one must be compilable even if sound is configured out
+obj-$(CONFIG_AC97_BUS) += ac97_bus.o
+obj-$(CONFIG_AC97_BUS_NEW) += ac97/
+
+ifeq ($(CONFIG_SND),y)
+ obj-y += last.o
+endif
+
+soundcore-objs := sound_core.o