summaryrefslogtreecommitdiffstats
path: root/sound/soc/mxs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sound/soc/mxs/Makefile')
-rw-r--r--sound/soc/mxs/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/sound/soc/mxs/Makefile b/sound/soc/mxs/Makefile
new file mode 100644
index 000000000..ab0a9a553
--- /dev/null
+++ b/sound/soc/mxs/Makefile
@@ -0,0 +1,11 @@
+# SPDX-License-Identifier: GPL-2.0
+# MXS Platform Support
+snd-soc-mxs-objs := mxs-saif.o
+snd-soc-mxs-pcm-objs := mxs-pcm.o
+
+obj-$(CONFIG_SND_MXS_SOC) += snd-soc-mxs.o snd-soc-mxs-pcm.o
+
+# i.MX Machine Support
+snd-soc-mxs-sgtl5000-objs := mxs-sgtl5000.o
+
+obj-$(CONFIG_SND_SOC_MXS_SGTL5000) += snd-soc-mxs-sgtl5000.o