summaryrefslogtreecommitdiffstats
path: root/sound/soc/sof/imx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sound/soc/sof/imx/Makefile')
-rw-r--r--sound/soc/sof/imx/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/sound/soc/sof/imx/Makefile b/sound/soc/sof/imx/Makefile
new file mode 100644
index 000000000..798b43a41
--- /dev/null
+++ b/sound/soc/sof/imx/Makefile
@@ -0,0 +1,11 @@
+# SPDX-License-Identifier: (GPL-2.0-only OR BSD-3-Clause)
+snd-sof-imx8-objs := imx8.o
+snd-sof-imx8m-objs := imx8m.o
+snd-sof-imx8ulp-objs := imx8ulp.o
+
+snd-sof-imx-common-objs := imx-common.o
+
+obj-$(CONFIG_SND_SOC_SOF_IMX8) += snd-sof-imx8.o
+obj-$(CONFIG_SND_SOC_SOF_IMX8M) += snd-sof-imx8m.o
+obj-$(CONFIG_SND_SOC_SOF_IMX8ULP) += snd-sof-imx8ulp.o
+obj-$(CONFIG_SND_SOC_SOF_IMX_COMMON) += imx-common.o