summaryrefslogtreecommitdiffstats
path: root/sound/soc/spear/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sound/soc/spear/Makefile')
-rw-r--r--sound/soc/spear/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/sound/soc/spear/Makefile b/sound/soc/spear/Makefile
new file mode 100644
index 000000000..31d9dae28
--- /dev/null
+++ b/sound/soc/spear/Makefile
@@ -0,0 +1,9 @@
+# SPDX-License-Identifier: GPL-2.0
+# SPEAR Platform Support
+snd-soc-spear-pcm-objs := spear_pcm.o
+snd-soc-spear-spdif-in-objs := spdif_in.o
+snd-soc-spear-spdif-out-objs := spdif_out.o
+
+obj-$(CONFIG_SND_SPEAR_SOC) += snd-soc-spear-pcm.o
+obj-$(CONFIG_SND_SPEAR_SPDIF_IN) += snd-soc-spear-spdif-in.o
+obj-$(CONFIG_SND_SPEAR_SPDIF_OUT) += snd-soc-spear-spdif-out.o