summaryrefslogtreecommitdiffstats
path: root/sound/synth/emux/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sound/synth/emux/Makefile')
-rw-r--r--sound/synth/emux/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/sound/synth/emux/Makefile b/sound/synth/emux/Makefile
new file mode 100644
index 000000000..ed28c81ac
--- /dev/null
+++ b/sound/synth/emux/Makefile
@@ -0,0 +1,14 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for ALSA
+# Copyright (c) 2001 by Jaroslav Kysela <perex@perex.cz>
+#
+
+snd-emux-synth-objs := emux.o emux_synth.o emux_seq.o emux_nrpn.o \
+ emux_effect.o emux_hwdep.o soundfont.o
+snd-emux-synth-$(CONFIG_SND_PROC_FS) += emux_proc.o
+ifneq ($(CONFIG_SND_SEQUENCER_OSS),)
+snd-emux-synth-y += emux_oss.o
+endif
+
+obj-$(CONFIG_SND_SYNTH_EMUX) += snd-emux-synth.o