summaryrefslogtreecommitdiffstats
path: root/tools/testing/selftests/powerpc/flags.mk
diff options
context:
space:
mode:
Diffstat (limited to 'tools/testing/selftests/powerpc/flags.mk')
-rw-r--r--tools/testing/selftests/powerpc/flags.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/tools/testing/selftests/powerpc/flags.mk b/tools/testing/selftests/powerpc/flags.mk
new file mode 100644
index 0000000000..abb9e58d95
--- /dev/null
+++ b/tools/testing/selftests/powerpc/flags.mk
@@ -0,0 +1,9 @@
+#This checks for any ENV variables and add those.
+
+ifeq ($(GIT_VERSION),)
+GIT_VERSION := $(shell git describe --always --long --dirty || echo "unknown")
+export GIT_VERSION
+endif
+
+CFLAGS := -std=gnu99 -O2 -Wall -Werror -DGIT_VERSION='"$(GIT_VERSION)"' -I$(selfdir)/powerpc/include $(USERCFLAGS)
+export CFLAGS