summaryrefslogtreecommitdiffstats
path: root/src/pcrepp/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:01:36 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:01:36 +0000
commit62e4c68907d8d33709c2c1f92a161dff00b3d5f2 (patch)
treeadbbaf3acf88ea08f6eeec4b75ee98ad3b07fbdc /src/pcrepp/CMakeLists.txt
parentInitial commit. (diff)
downloadlnav-28bf0ff1a7ad38ac9ddb1f5864ba0161b0617471.tar.xz
lnav-28bf0ff1a7ad38ac9ddb1f5864ba0161b0617471.zip
Adding upstream version 0.11.2.upstream/0.11.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/pcrepp/CMakeLists.txt')
-rw-r--r--src/pcrepp/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/pcrepp/CMakeLists.txt b/src/pcrepp/CMakeLists.txt
new file mode 100644
index 0000000..1af8845
--- /dev/null
+++ b/src/pcrepp/CMakeLists.txt
@@ -0,0 +1,16 @@
+add_library(pcrepp STATIC
+ ../config.h.in
+ pcre2pp.hh
+ pcre2pp.cc)
+
+target_include_directories(pcrepp PUBLIC . .. ../third-party/scnlib/include
+ ${CMAKE_CURRENT_BINARY_DIR}/..)
+target_link_libraries(pcrepp cppfmt pcre::libpcre pcre2::pcre2)
+
+add_executable(test_pcre2pp test_pcre2pp.cc)
+target_include_directories(
+ test_pcre2pp
+ PUBLIC
+ ../third-party/doctest-root)
+target_link_libraries(test_pcre2pp pcrepp)
+add_test(NAME test_pcre2pp COMMAND test_pcre2pp)