summaryrefslogtreecommitdiffstats
path: root/src/base/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/base/Makefile.am')
-rw-r--r--src/base/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/src/base/Makefile.am b/src/base/Makefile.am
index 4a459a6..105913f 100644
--- a/src/base/Makefile.am
+++ b/src/base/Makefile.am
@@ -7,6 +7,7 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/src/ \
-I$(top_srcdir)/src/third-party \
-I$(top_srcdir)/src/fmtlib \
+ -I$(top_srcdir)/src/third-party/date/include \
-I$(top_srcdir)/src/third-party/scnlib/include \
$(LIBARCHIVE_CFLAGS) \
$(READLINE_CFLAGS) \
@@ -22,15 +23,19 @@ noinst_LIBRARIES = libbase.a
noinst_HEADERS = \
ansi_scrubber.hh \
+ ansi_vars.hh \
attr_line.hh \
attr_line.builder.hh \
auto_fd.hh \
auto_mem.hh \
auto_pid.hh \
bus.hh \
+ color_spaces.hh \
+ date_time_scanner.cfg.hh \
date_time_scanner.hh \
enum_util.hh \
file_range.hh \
+ from_trait.hh \
fs_util.hh \
func_util.hh \
future_util.hh \
@@ -43,28 +48,35 @@ noinst_HEADERS = \
is_utf8.hh \
isc.hh \
itertools.hh \
+ keycodes.hh \
+ line_range.hh \
lnav_log.hh \
lnav.console.hh \
lnav.console.into.hh \
lnav.gzip.hh \
log_level_enum.hh \
lrucache.hpp \
+ map_util.hh \
math_util.hh \
network.tcp.hh \
opt_util.hh \
paths.hh \
+ piper.file.hh \
result.h \
snippet_highlighters.hh \
string_attr_type.hh \
string_util.hh \
strnatcmp.h \
- time_util.hh
+ time_util.hh \
+ types.hh
libbase_a_SOURCES = \
ansi_scrubber.cc \
attr_line.cc \
attr_line.builder.cc \
+ auto_fd.cc \
auto_pid.cc \
+ color_spaces.cc \
date_time_scanner.cc \
fs_util.cc \
humanize.cc \
@@ -78,6 +90,7 @@ libbase_a_SOURCES = \
lnav_log.cc \
network.tcp.cc \
paths.cc \
+ piper.file.cc \
snippet_highlighters.cc \
string_attr_type.cc \
string_util.cc \
@@ -103,6 +116,7 @@ test_base_SOURCES = \
test_base_LDADD = \
libbase.a \
../fmtlib/libcppfmt.a \
+ ../third-party/date/src/libdatepp.a \
../third-party/scnlib/src/libscnlib.a \
../pcrepp/libpcrepp.a