summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--test/Makefile.am89
1 files changed, 83 insertions, 6 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index a92ceb8..f7d83f7 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -12,17 +12,29 @@ AM_LIBS = $(CODE_COVERAGE_LIBS)
AM_CFLAGS = $(CODE_COVERAGE_CFLAGS)
AM_CXXFLAGS = $(CODE_COVERAGE_CXXFLAGS)
+if HAVE_CARGO
+RUST_DEPS_CPPFLAGS = -I$(top_srcdir)/src/third-party/prqlc-c -DHAVE_RUST_DEPS=1
+PRQLC_DIR = ../src/third-party/prqlc-c/target
+RUST_DEPS_LIBS = $(PRQLC_DIR)/release/libprqlc_c.a
+else
+RUST_DEPS =
+RUST_DEPS_CPPFLAGS =
+RUST_DEPS_LIBS =
+endif
+
AM_CPPFLAGS = \
-Wall \
-I$(top_srcdir)/src \
-I$(top_srcdir)/src/fmtlib \
-I$(top_srcdir)/src/third-party \
+ -I$(top_srcdir)/src/third-party/date/include \
-I$(top_srcdir)/src/third-party/scnlib/include \
$(CODE_COVERAGE_CPPFLAGS) \
$(LIBARCHIVE_CFLAGS) \
$(READLINE_CFLAGS) \
$(PCRE_CFLAGS) \
- $(SQLITE3_CFLAGS)
+ $(SQLITE3_CFLAGS) \
+ $(RUST_DEPS_CPPFLAGS)
# AM_CFLAGS = -fprofile-arcs -ftest-coverage
# AM_CXXFLAGS = -fprofile-arcs -ftest-coverage
@@ -51,6 +63,7 @@ DUMMY_OBJS = \
check_PROGRAMS = \
drive_data_scanner \
+ drive_doc_discovery \
drive_line_buffer \
drive_grep_proc \
drive_listview \
@@ -113,13 +126,15 @@ LDADD = \
$(top_builddir)/src/base/libbase.a \
$(top_builddir)/src/pugixml/libpugixml.a \
$(top_builddir)/src/third-party/base64/lib/libbase64.a \
+ $(top_builddir)/src/third-party/date/src/libdatepp.a \
$(top_builddir)/src/third-party/scnlib/src/libscnlib.a \
$(READLINE_LIBS) \
$(CURSES_LIB) \
$(LIBARCHIVE_LIBS) \
$(SQLITE3_LIBS) \
$(PCRE_LIBS) \
- $(LIBCURL)
+ $(LIBCURL) \
+ $(RUST_DEPS_LIBS)
test_ansi_scrubber_SOURCES = test_ansi_scrubber.cc
@@ -162,6 +177,9 @@ drive_shlexer_SOURCES = drive_shlexer.cc
drive_data_scanner_SOURCES = \
drive_data_scanner.cc
+drive_doc_discovery_SOURCES = \
+ drive_doc_discovery.cc
+
drive_mvwattrline_SOURCES = drive_mvwattrline.cc
drive_view_colors_SOURCES = drive_view_colors.cc
@@ -188,6 +206,7 @@ dist_noinst_SCRIPTS = \
test_events.sh \
test_format_installer.sh \
test_format_loader.sh \
+ test_gantt.sh \
test_grep_proc.sh \
test_json_format.sh \
test_line_buffer.sh \
@@ -195,6 +214,7 @@ dist_noinst_SCRIPTS = \
test_logfile.sh \
test_meta.sh \
test_mvwattrline.sh \
+ test_prql.sh \
test_regex101.sh \
test_remote.sh \
test_scripts.sh \
@@ -226,7 +246,10 @@ dist_noinst_DATA = \
expected/test_tailer.sh_12f539e535df04364316699f9edeac461aa9f9de.err \
expected/test_tailer.sh_12f539e535df04364316699f9edeac461aa9f9de.out \
ansi-colors.0.in \
+ bad-config/formats/invalid-file-format/format.json \
bad-config/formats/invalid-json-format/format.json \
+ bad-config/formats/invalid-name/format.json \
+ bad-config/formats/invalid-no-tscap/format.json \
bad-config/formats/invalid-properties/format.json \
bad-config/formats/invalid-regex/format.json \
bad-config/formats/invalid-sample/format.json \
@@ -235,12 +258,15 @@ dist_noinst_DATA = \
bad-config/formats/invalid-sql/init2.sql \
bad-config/formats/no-regexes/format.json \
bad-config/formats/no-samples/format.json \
+ bad-config2/configs/invalid-annotation/config.json \
+ bad-config2/configs/invalid-theme/config.json \
bad-config2/formats/invalid-config/config.json \
bad-config2/formats/invalid-config/config.bad-schema.json \
bad-config2/formats/invalid-config/config.malformed.json \
bad-config2/formats/invalid-config/config.truncated.json \
bad-config-json/formats/invalid-json/format.json \
bad-config-json/formats/invalid-key/format.json \
+ books.json \
books.xml \
file_for_dot_read.sql \
datafile_simple.0 \
@@ -269,7 +295,11 @@ dist_noinst_DATA = \
datafile_xml.0 \
dhcp.pcapng \
dhcp-trunc.pcapng \
+ example.patch \
+ example.toml \
expected_help.txt \
+ gharchive_log.jsonl \
+ invalid-books.xml \
listview_output.0 \
listview_output.1 \
listview_output.2 \
@@ -324,10 +354,13 @@ dist_noinst_DATA = \
logfile_logfmt.0 \
logfile_multiline.0 \
logfile_nested_json.json \
+ logfile_nextcloud.0 \
logfile_openam.0 \
+ logfile_partitions.0 \
logfile_plain.0 \
logfile_pretty.0 \
logfile_procstate.0 \
+ logfile_regexp_access_log.0 \
logfile_rollover.0 \
logfile_rollover.1 \
logfile_strace_log.0 \
@@ -357,15 +390,20 @@ dist_noinst_DATA = \
logfile_w3c.6 \
logfile_w3c_big.0 \
logfile_with_a_really_long_name_to_test_a_bug_with_long_names.0 \
+ logfile_with_zones.0 \
logfile_xml_msg.0 \
+ man_echo.txt \
multiline.lnav \
- nested.lnav \
mvwattrline_output.0 \
+ nested.lnav \
+ pyfile_0.py \
textfile_0.md \
textfile_ansi.0 \
textfile_ansi_expanding.0 \
textfile_json_indented.0 \
textfile_json_one_line.0 \
+ textfile_nonl.txt \
+ textfile_plain.0 \
textfile_quoted_json.0 \
toplevel.lnav \
UTF-8-test.txt \
@@ -375,6 +413,10 @@ dist_noinst_DATA = \
vt52_curses_output.0 \
vt52_curses_output.1 \
xpath_tui.0 \
+ configs/installed/anno-test.json \
+ configs/installed/anno-test.sh \
+ configs/installed/hw-url-handler.json \
+ configs/installed/hw-url-handler.lnav \
formats/collision/format.json \
formats/customlevel/format.json \
formats/jsontest/format.json \
@@ -384,15 +426,41 @@ dist_noinst_DATA = \
formats/jsontest3/format.json \
formats/jsontest-subsec/format.json \
formats/nestedjson/format.json \
+ formats/partitions/format.json \
formats/scripts/multiline-echo.lnav \
formats/scripts/redirecting.lnav \
formats/scripts/nested-redirecting.lnav \
formats/sqldir/init.sql \
formats/timestamp/format.json \
formats/xmlmsg/format.json \
- log-samples/sample-27353a72ba4025448f261dcfa6ea16e474187795.txt \
- log-samples/sample-70c906b3c1a1cf03f15bde92ee78edfa6f9b7960.txt \
- log-samples/sample-ad31f12d2adabd07e3ddda3ad5b0dbf6b49c4c99.txt \
+ log-samples/sample-057d6c669632ef9d07b6adec605f6bdeae19af27.txt \
+ log-samples/sample-06aaa6f48a801f592558575d886864d6c3ab9ed4.txt \
+ log-samples/sample-1aeb47c0a97d19bb7418f0172480e05e49c6e53e.txt \
+ log-samples/sample-27353a72ba4025448f261dcfa6ea16e474187795.txt \
+ log-samples/sample-3856ad0f551a04fde41a020158d6b33ef97c870a.txt \
+ log-samples/sample-45364b3fd51af92a4ad8a309b5f4fd88.txt \
+ log-samples/sample-500c9e492e04f5f58862c8086ca301de0dd976ce.txt \
+ log-samples/sample-55ac97afae4b0650ccb62e2dbc8d89bb.txt \
+ log-samples/sample-6049d4309f26eefb1a3406d937a9ba8a0df592a7.txt \
+ log-samples/sample-62315d884afdc4155b35f905415c74bfcfd39fc2.txt \
+ log-samples/sample-70c906b3c1a1cf03f15bde92ee78edfa6f9b7960.txt \
+ log-samples/sample-9cf7fbb3546c676c686fac0ed096d026f46c875f.txt \
+ log-samples/sample-a74570613c082c7fe283672031e18e54e8887ffb.txt \
+ log-samples/sample-aca2878a2e50779c6697c0747ab1f60e4b368dcb.txt \
+ log-samples/sample-ad31f12d2adabd07e3ddda3ad5b0dbf6b49c4c99.txt \
+ log-samples/sample-bc6f6cf689fa5455616b4d9fbe121a48d3c9de59.txt \
+ log-samples/sample-c15acd32844669d23d0cbc88ec548129ed2c592e.txt \
+ log-samples/sample-c23f22c1b932b904203e018f78dead95fb89b15d.txt \
+ log-samples/sample-d0d6b3fc6766caac5ac3fac4a3754ceaab785eb8.txt \
+ log-samples/sample-d4a0aedc8350f64b22403eeef4eca71fbf749d2b.txt \
+ log-samples/sample-d714b5e8cd354321f376ed1c0a70ec9a2f58076d.txt \
+ log-samples/sample-dd7d406352ec6a11d966b6f015a9482b060f2b29.txt \
+ log-samples/sample-e779d1771e34f5203ae73e85802e78002be63db6.txt \
+ log-samples/sample-eef32793daf841a576d8a5cd27239d5d.txt \
+ log-samples/sample-f2fba0d0b1e57f9a707ea96a8a4efcdc.txt \
+ log-samples/sample-f5afbee90a8c054061c4e9ffe673293cce7761de.txt \
+ log-samples/sample-fc8923633e57bacd641d80dde3ff878212230552.txt \
+ naughty_files.py \
remote-log-dir/logfile_access_log.0 \
remote-log-dir/logfile_access_log.1 \
tui-captures/tui_echo.0 \
@@ -415,6 +483,7 @@ TESTS = \
test_listview.sh \
test_meta.sh \
test_mvwattrline.sh \
+ test_gantt.sh \
test_grep_proc.sh \
test_grep_proc2 \
test_json_format.sh \
@@ -445,6 +514,10 @@ TESTS = \
test_view_colors.sh \
test_vt52_curses.sh
+if HAVE_CARGO
+TESTS += test_prql.sh
+endif
+
DISABLED_TESTS = \
test_regex101.sh \
test_remote.sh \
@@ -507,8 +580,12 @@ distclean-local:
$(RM_V)rm -rf remote remote-tmp not:a:remote:dir
$(RM_V)rm -rf sessions
$(RM_V)rm -rf tmp
+ $(RM_V)rm -rf piper-tmp
$(RM_V)rm -rf rotmp
$(RM_V)rm -rf meta-sessions
+ $(RM_V)rm -rf mgmt-config
+ $(RM_V)rm -rf naughty
+ $(RM_V)rm -rf piper-config
$(RM_V)rm -rf nested
$(RM_V)rm -rf test-config
$(RM_V)rm -rf .lnav