summaryrefslogtreecommitdiffstats
path: root/.vscode
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 19:55:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 19:55:48 +0000
commit8be448d3881909fb0ce4b033cad71aa7575de0aa (patch)
treeda33caff06645347a08c3c9c56dd703e4acb5aa3 /.vscode
parentInitial commit. (diff)
downloadlsprotocol-8be448d3881909fb0ce4b033cad71aa7575de0aa.tar.xz
lsprotocol-8be448d3881909fb0ce4b033cad71aa7575de0aa.zip
Adding upstream version 2023.0.0.upstream/2023.0.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '.vscode')
-rw-r--r--.vscode/extensions.json9
-rw-r--r--.vscode/launch.json35
-rw-r--r--.vscode/settings.json23
3 files changed, 67 insertions, 0 deletions
diff --git a/.vscode/extensions.json b/.vscode/extensions.json
new file mode 100644
index 0000000..e6d1a11
--- /dev/null
+++ b/.vscode/extensions.json
@@ -0,0 +1,9 @@
+{
+ "recommendations": [
+ "esbenp.prettier-vscode",
+ "ms-python.python",
+ "ms-python.vscode-pylance",
+ "ms-python.black-formatter",
+ "ms-python.isort"
+ ]
+}
diff --git a/.vscode/launch.json b/.vscode/launch.json
new file mode 100644
index 0000000..095615f
--- /dev/null
+++ b/.vscode/launch.json
@@ -0,0 +1,35 @@
+{
+ "version": "0.2.0",
+ "configurations": [
+ {
+ "name": "Run Generator",
+ "type": "python",
+ "request": "launch",
+ "module": "generator",
+ "console": "integratedTerminal",
+ "justMyCode": true,
+ "args": ["--plugin", "${input:plugin}"]
+ },
+ {
+ "name": "DON'T SELECT (test debug config)",
+ "type": "python",
+ "request": "launch",
+ "console": "integratedTerminal",
+ "justMyCode": false,
+ "purpose": ["debug-test"],
+ "presentation": {
+ "hidden": true,
+ "group": "",
+ "order": 4
+ }
+ }
+ ],
+ "inputs": [
+ {
+ "id": "plugin",
+ "type": "pickString",
+ "description": "Select a plugin to debug",
+ "options": ["python", "rust", "dotnet", "testdata"]
+ }
+ ]
+}
diff --git a/.vscode/settings.json b/.vscode/settings.json
new file mode 100644
index 0000000..9df63e5
--- /dev/null
+++ b/.vscode/settings.json
@@ -0,0 +1,23 @@
+{
+ "files.exclude": {
+ "**/.git": true,
+ "**/__pycache__": true,
+ "**/.mypy_cache": true,
+ "**/.pytest_cache": true,
+ "**/.nox": true
+ },
+ "python.formatting.provider": "none",
+ "editor.formatOnSave": true,
+ "editor.codeActionsOnSave": {
+ "source.organizeImports": true
+ },
+ "[python]": {
+ "editor.defaultFormatter": "ms-python.black-formatter"
+ },
+ "isort.args": ["--profile", "black"],
+ "python.testing.pytestArgs": ["tests"],
+ "python.testing.unittestEnabled": false,
+ "python.testing.pytestEnabled": true,
+ "python.analysis.extraPaths": ["packages/python", "tests/python/common"],
+ "rust-analyzer.linkedProjects": ["packages/rust/lsprotocol/Cargo.toml"]
+}