summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:21:24 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:21:24 +0000
commit6ab76b82bd03cb06a60a04bb1aa0544d16d6b81e (patch)
tree92ffa8378f3f78a4b8f758c9d1eafe9b024be9c1 /debian/rules
parentAdding upstream version 2.9.0rel.0. (diff)
downloadlynx-6ab76b82bd03cb06a60a04bb1aa0544d16d6b81e.tar.xz
lynx-6ab76b82bd03cb06a60a04bb1aa0544d16d6b81e.zip
Adding debian version 2.9.0rel.0-2.debian/2.9.0rel.0-2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules79
1 files changed, 79 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..f995c54
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,79 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_CFLAGS_MAINT_APPEND := -Wall -DNO_BUILDSTAMP
+
+SSL=gnu
+# uncomment the next line if you want openssl version
+#SSL=ssl
+
+ifeq ($(SSL),gnu)
+ CONFTLS := --with-gnutls=/usr
+else
+ CONFTLS := --with-ssl
+endif
+
+override_dh_auto_configure:
+ifeq ($(SSL),gnu)
+ sed -i -e s/libssl-dev/libgnutls28-dev/g debian/control
+else
+ sed -i -e s/libgnutls28-dev/libssl-dev/g debian/control
+endif
+
+ env cf_cv_SYSTEM_MAIL=/usr/sbin/sendmail \
+ LIBS="-lbsd" \
+ dh_auto_configure --verbose -- \
+ --enable-8bit-toupper \
+ --enable-cgi-links \
+ --enable-cjk \
+ --enable-debug \
+ --enable-default-colors \
+ --enable-exec-links \
+ --enable-exec-scripts \
+ --enable-externs \
+ --enable-forms-options \
+ --enable-gzip-help \
+ --enable-htmlized-cfg \
+ --enable-ipv6 \
+ --enable-japanese-utf8 \
+ --enable-justify-elts \
+ --enable-justify-elts \
+ --enable-nested-tables \
+ --enable-nls \
+ --enable-nsl-fork \
+ --enable-partial \
+ --enable-persistent-cookies \
+ --enable-prettysrc \
+ --enable-read-eta \
+ --enable-scrollbar \
+ --enable-source-cache \
+ --enable-syslog \
+ --sysconfdir=/etc/lynx \
+ --with-brotli \
+ --with-bzlib \
+ --without-included-gettext \
+ --with-screen=ncursesw \
+ --with-zlib \
+ COMPRESS=/usr/bin/compress \
+ ZIP=/usr/bin/zip \
+ $(CONFTLS)
+
+override_dh_autoreconf:
+ dh_autoreconf autoreconf-dickey -- -f -i
+
+override_dh_auto_install:
+ dh_auto_install --verbose -- install-full
+ cd debian/tmp/usr/share/lynx_help && rm -vf COPYING COPYHEADER
+ cd debian/tmp/usr/share/lynx_doc && rm -rvf CHANGES \
+ COPYHEADER.asc COPYING COPYING.asc samples test
+ sed -i -e '/^# *\$$LynxId: /d' \
+ -e '/^# *LYNX_VERSION *"/d' \
+ -e '/^# *LYNX_DATE *"/d' \
+ debian/tmp/etc/lynx/lynx.*
+
+override_dh_link:
+ rm -fv debian/lynx/usr/share/doc/lynx/changelog
+ dh_link
+
+%:
+ dh $@