summaryrefslogtreecommitdiffstats
path: root/ChangeLog
diff options
context:
space:
mode:
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog289
1 files changed, 289 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index 550c635..885c4fe 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,292 @@
+2024-04-05 Colin Watson <cjwatson@debian.org>
+
+ Release man-db 2.12.1
+
+2024-04-05 Colin Watson <cjwatson@debian.org>
+
+ Rebase argp-domain patch onto current Gnulib
+
+ * patches/argp-domain.patch: Rebase and resolve conflict.
+
+2024-03-31 Colin Watson <cjwatson@debian.org>
+
+ Fix excessive cleanup of /var/cache/man by systemd-tmpfiles
+
+ Fixes https://gitlab.com/man-db/man-db/-/issues/36.
+
+ * init/systemd/man-db.conf.in: Only consider access times. Ignore
+ `/var/cache/man/index*` and `/var/cache/man/*/index*`.
+ * NEWS.md: Document this.
+
+2024-03-29 Seong-ho Cho <darkcircle.0426@gmail.com>
+
+ Update Korean manual page translation
+
+ * man/po4a/po/ko.po: Update from Translation Project.
+
+2024-03-29 Mario Blättermann <mario.blaettermann@gmail.com>
+
+ Update German manual page translation
+
+ * man/po4a/po/de.po: Update from Translation Project.
+
+2024-03-28 Remus-Gabriel Chelu <remusgabriel.chelu@disroot.org>
+
+ Update Romanian manual page translation
+
+ * man/po4a/po/ro.po: Update from Translation Project.
+
+2024-03-28 Colin Watson <cjwatson@debian.org>
+
+ Release man-db 2.12.1-pre1
+
+2024-03-28 Colin Watson <cjwatson@debian.org>
+
+ Update translation files
+
+ * man/po4a/po/*.pot, man/po4a/po/*.po, po/*.pot, po/*.po: Update.
+
+2024-03-28 Colin Watson <cjwatson@debian.org>
+
+ Update pre-commit hooks
+
+ * .pre-commit-config.yaml (shellcheck-py): Update to v0.10.0.1.
+ * src/tests/mandb-purge-updates-timestamp: Disable shellcheck SC2319;
+ the use of `$?` here is not problematic.
+ * tools/checkman: Use `find -newer` rather than non-POSIX `test -nt`.
+
+2024-03-28 Colin Watson <cjwatson@debian.org>
+
+ Document italic formatting
+
+ Fixes https://gitlab.com/man-db/man-db/-/issues/35.
+
+ * man/man1/man.man1 (ENVIRONMENT): Give `MANROFFOPT=-P-i` as an example.
+ * NEWS.md: Document this.
+
+2024-03-19 Colin Watson <cjwatson@debian.org>
+
+ Move setting of seccomp attributes earlier
+
+ This doesn't need to be done every time we load the filter; it can be
+ done when constructing the filter instead.
+
+ * lib/sandbox.c (_sandbox_load): Move `seccomp_attr_set` call to ...
+ (make_seccomp_filter): ... here.
+
+2024-03-18 Colin Watson <cjwatson@debian.org>
+
+ web: Update bootstrapping instructions
+
+ * web/development.html: Bootstrapping from git now requires
+ `./bootstrap` rather than `./autogen.sh`.
+
+2024-03-18 Colin Watson <cjwatson@debian.org>
+
+ Tighten up several declarations
+
+ * lib/cleanup.c (untrap_signal, pop_cleanup): Constify argument.
+ * lib/cleanup.h (pop_cleanup): Update prototype.
+ * src/decompress.c (decompress_is_pipeline): Constify argument.
+ * src/decompress.h (decompress_is_pipeline): Update prototype.
+ * src/mandb.c (dbpaths_copy_to_tmp, dbpaths_remove_tmp,
+ dbpaths_unlink_tmp): Constify argument.
+ * src/ult_src.c (ult_key_equals): Constify variable declarations.
+ * src/whatis.c (any_set, all_set): Constify argument.
+ (match): Constify variable declarations.
+ (do_apropos): Constify argument to `combine`.
+
+ * lib/encodings.c (get_less_charset, get_jless_charset): Narrow variable
+ scope.
+ * src/check_mandirs.c (mkcatdirs): Likewise.
+
+2024-03-03 Colin Watson <cjwatson@debian.org>
+
+ Speed up seccomp filter slightly
+
+ Thanks to systemd for the idea. With a couple of hundred entries in the
+ filter (depending on architecture and permissiveness), using a binary-tree
+ search should be worth it.
+
+ * lib/sandbox.c (_sandbox_load): Set `SCMP_FLTATR_CTL_OPTIMIZE` to 2 if
+ available.
+ * NEWS.md: Document this.
+
+2024-03-03 Colin Watson <cjwatson@debian.org>
+
+ Update syscall lists from systemd 85b774de49
+
+ * lib/sandbox.c (make_seccomp_filter): Add `fchmodat2`.
+
+2024-03-03 Colin Watson <cjwatson@debian.org>
+
+ Mention groff's pdf device
+
+ Fixes https://gitlab.com/man-db/man-db/-/issues/34.
+
+ * man/man1/man.man1 (Controlling formatted output): Add pdf to the list
+ of groff devices.
+ * NEWS.md: Document this.
+
+2024-01-28 Colin Watson <cjwatson@debian.org>
+
+ pre-commit: Add perlcritic
+
+ * .pre-commit-config.yaml: Add perlcritic.
+ * man/po4a/Locale/Po4a/Manext.pm (initialize, pushline): Add explicit
+ return statements at end.
+ (translate): Unpack `@_` first in a way that perlcritic recognizes.
+
+2024-01-28 Colin Watson <cjwatson@debian.org>
+
+ Remove obsolete chconfig tool
+
+ The FHS transition took place almost 25 years ago (at least in Debian),
+ so it's not worth keeping this around now.
+
+ * tools/chconfig: Remove.
+ * tools/Makefile.am (dist_noinst_SCRIPTS): Remove chconfig.
+ * tools/README: Likewise.
+ * NEWS.md: Document this.
+
+2024-01-20 Colin Watson <cjwatson@debian.org>
+
+ Update pre-commit hooks
+
+ * .pre-commit-config.yaml (pre-commit-hooks): Update to v4.5.0.
+ (shellcheck-py): Update to v0.9.0.6.
+
+2024-01-20 Colin Watson <cjwatson@debian.org>
+
+ Upgrade to Gnulib stable-202401
+
+ * bootstrap: Sync to Gnulib c78af17a931bb36e00c5f698b7fd37deb4a87f58.
+ * bootstrap.conf (GNULIB_REVISION): Set to
+ c78af17a931bb36e00c5f698b7fd37deb4a87f58.
+ * NEWS.md: Document this.
+
+2024-01-17 Sebastian Rasmussen <sebras@gmail.com>
+
+ Update Swedish manual page translation
+
+ * man/po4a/po/sv.po: Update from Translation Project.
+
+2024-01-17 Sebastian Rasmussen <sebras@gmail.com>
+
+ Update Swedish translation
+
+ * po/sv.po: Update from Translation Project.
+
+2024-01-10 Мирослав Николић <miroslavnikolic@rocketmail.com>
+
+ Update Serbian translation
+
+ * po/sr.po: Update from Translation Project.
+
+2023-12-30 Colin Watson <cjwatson@debian.org>
+
+ NEWS: Document previous commit
+
+ Fixes https://bugs.debian.org/1059537.
+
+2023-12-30 Colin Watson <cjwatson@chiark.greenend.org.uk>
+
+ Merge branch 'main' into 'main'
+
+ man: match the display width to the configured width
+
+ See merge request man-db/man-db!11
+
+2023-12-30 наб <nabijaczleweli@nabijaczleweli.xyz>
+
+ man: enforce a single-column right margin
+
+ Under groff, tbl consistently overruns the page width by one column,
+ so accommodate this.
+
+ Ref: https://gitlab.com/man-db/man-db/-/merge_requests/11#note_1708513108
+
+2023-12-28 наб <nabijaczleweli@nabijaczleweli.xyz>
+
+ man: match the display width to the configured width
+
+ Currently, the line length is:
+ if w ≤ 40: w - 2
+ else : ⌊w*(39/40)⌋
+ i.e.
+ if w ≤ 40: w - 2
+ else : w - ⌈w/40⌉
+ (this is equivalent to a ≤80 condition).
+
+ This was originally originally introduced in commit
+ f139e8273d5f3754f0d0dacb890e515b30c2d28b ("Add terminal line length
+ detection to man.") from 2001-06-28, which did
+ if w ∈ [66, 80]: 80 (via default)
+ else : ⌊.9w⌋
+ then tracked the default in
+ commit cac2ef84fe626f112de7537c20dfe29c35a71b96 ("Update default
+ line length in line with groff 1.18.") from 2002-07-06,
+ which updates it to the current formula,
+ then commit 39cdee4ada59d711d066628ec827508070d90a70 ("Always pass a
+ line length to nroff") from 2023-08-06 removes any defaulting.
+
+ This is ideologically quite weird, because this behaves like a
+ stochastic best-effort fit so there is always a blank margin, growing
+ with size, derived from a 21-year-old default which was only relevant
+ because catpages were vaguely relevant, even though we perfectly
+ know how large we need to display the manual by virtue of perfectly
+ knowing the size of the teletype! There is no such margin on the
+ left, and why would there be?
+
+ Fixes Debian bug #1059537.
+
+2023-12-28 наб <nabijaczleweli@nabijaczleweli.xyz>
+
+ man: simplify the right-margin condition
+
+ As it stands, this is
+ ⌊line_length*(39/40)⌋ > line_length - 2
+ which works out to
+ line_length ≤ 40
+ Is that obvious? No (I analysed it to line_length < 80),
+ but the way the result is used makes it equivalent to
+ line_length ≤ 80
+ anyway.
+
+ This currently blames to commit cac2ef84fe626f112de7537c20dfe29c35a71b96
+ ("Update default line length in line with groff 1.18.") dated
+ 2002-07-06 20:30:34 +0000(!) with a diff of
+ - if (!troff && (line_length < 66 || line_length > 80))
+ - return line_length * 9 / 10;
+ + /* groff >= 1.18 defaults to 78. */
+ + if (!troff && line_length != 80) {
+ + int length = line_length * 39 / 40;
+ + if (length > line_length - 2)
+ + return line_length - 2;
+ + else
+ + return length;
+
+ NFC
+
+2023-12-18 Yuri Kozlov <yuray@komyakino.ru>
+
+ Update Russian manual page translation
+
+ * man/po4a/po/ru.po: Update from Translation Project.
+
+2023-12-18 Yuri Kozlov <yuray@komyakino.ru>
+
+ Update Russian translation
+
+ * po/ru.po: Update from Translation Project.
+
+2023-12-08 Colin Watson <cjwatson@debian.org>
+
+ Upgrade to Gnulib stable-202307 as of 20231208
+
+ * bootstrap.conf (GNULIB_REVISION): Set to
+ 51ff7c1242903bcc90b35baf5ec2e6a176cf912a.
+
2023-09-23 Colin Watson <cjwatson@debian.org>
Release man-db 2.12.0