summaryrefslogtreecommitdiffstats
path: root/po/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 19:43:11 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 19:43:11 +0000
commitfc22b3d6507c6745911b9dfcc68f1e665ae13dbc (patch)
treece1e3bce06471410239a6f41282e328770aa404a /po/Makefile.am
parentInitial commit. (diff)
downloadmanpages-l10n-fc22b3d6507c6745911b9dfcc68f1e665ae13dbc.tar.xz
manpages-l10n-fc22b3d6507c6745911b9dfcc68f1e665ae13dbc.zip
Adding upstream version 4.22.0.upstream/4.22.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'po/Makefile.am')
-rw-r--r--po/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/po/Makefile.am b/po/Makefile.am
new file mode 100644
index 00000000..b8a79877
--- /dev/null
+++ b/po/Makefile.am
@@ -0,0 +1,32 @@
+# Makefile for manpages-l10n
+#
+# Copyright © 2017-2019 Dr. Tobias Quathamer <toddy@debian.org>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+SUBDIRS = cs da de el es fi fr hu nb nl id it ko mk pl pt_BR ro ru sr sv uk vi
+
+
+# Reformat all .po files and commit changes
+.PHONY: reformat
+reformat:
+ for d in $(SUBDIRS) ; do \
+ cd $$d && make reformat && cd .. ; \
+ done
+
+# Reformat and update all .po files and commit changes
+.PHONY: update-po
+update-po: reformat
+ $(srcdir)/update-translations.py ; \
+ git commit -m "Update .po files from templates and common messages" . || true