summaryrefslogtreecommitdiffstats
path: root/upstream/archlinux/man8/makepkg.8
diff options
context:
space:
mode:
Diffstat (limited to 'upstream/archlinux/man8/makepkg.8')
-rw-r--r--upstream/archlinux/man8/makepkg.850
1 files changed, 35 insertions, 15 deletions
diff --git a/upstream/archlinux/man8/makepkg.8 b/upstream/archlinux/man8/makepkg.8
index db2e52e2..729330d0 100644
--- a/upstream/archlinux/man8/makepkg.8
+++ b/upstream/archlinux/man8/makepkg.8
@@ -2,12 +2,12 @@
.\" Title: makepkg
.\" Author: [see the "Authors" section]
.\" Generator: DocBook XSL Stylesheets vsnapshot <http://docbook.sf.net/>
-.\" Date: 2024-02-06
+.\" Date: 2024-03-15
.\" Manual: Pacman Manual
-.\" Source: Pacman 6.0.2
+.\" Source: Pacman 6.1.0
.\" Language: English
.\"
-.TH "MAKEPKG" "8" "2024\-02\-06" "Pacman 6\&.0\&.2" "Pacman Manual"
+.TH "MAKEPKG" "8" "2024\-03\-15" "Pacman 6\&.1\&.0" "Pacman Manual"
.\" -----------------------------------------------------------------
.\" * Define some portability stuff
.\" -----------------------------------------------------------------
@@ -101,7 +101,7 @@ PKGDEST
.PP
\fB\-g, \-\-geninteg\fR
.RS 4
-For each source file in the source array of PKGBUILD, download the file if required and generate integrity checks\&. The integrity checks generated are determined by the checks present in the PKGBUILD, falling back to the value of the INTEGRITY_CHECK array in makepkg\&.conf(5) if these are absent This output can be redirected into your PKGBUILD for source validation using "makepkg \-g >> PKGBUILD"\&.
+For each source file in the source array of PKGBUILD, download the file if required and generate integrity checks\&. The integrity checks generated are determined by the checks present in the PKGBUILD, falling back to the value of the INTEGRITY_CHECK array in makepkg\&.conf(5) if these are absent\&. This output can be redirected into your PKGBUILD for source validation using "makepkg \-g >> PKGBUILD"\&.
.RE
.PP
\fB\-\-skipinteg\fR
@@ -198,6 +198,11 @@ Display version information\&.
Remove the $srcdir before building the package\&.
.RE
.PP
+\fB\-D\fR <dir>, \fB\-\-dir\fR <dir>
+.RS 4
+Change to directory <dir> before reading the PKGBUILD or doing anything else\&.
+.RE
+.PP
\fB\-\-allsource\fR
.RS 4
Do not actually build the package, but build a source\-only tarball that includes all sources, including those that are normally downloaded via makepkg\&. This is useful for passing a single tarball to another program such as a chroot or remote builder\&. It will also satisfy requirements of the GPL when distributing binary packages\&.
@@ -224,6 +229,11 @@ Do not run the check() function in the PKGBUILD or handle the checkdepends\&.
Do not run the prepare() function in the PKGBUILD\&.
.RE
.PP
+\fB\-\-noverify\fR
+.RS 4
+Do not run the verify() function in the PKGBUILD\&.
+.RE
+.PP
\fB\-\-sign\fR
.RS 4
Sign the resulting package with gpg, overriding the setting in
@@ -286,6 +296,11 @@ makepkg is designed to be compatible with Reproducible Builds\&. If the \fBSOURC
If the \fBSOURCE_DATE_EPOCH\fR environment variable is not set, makepkg will use its own start date for internal use, but will not unify source file timestamps before building\&.
.SH "ENVIRONMENT VARIABLES"
.PP
+\fBMAKEPKG_LIBRARY\fR="/path/to/directory"
+.RS 4
+Use an alternative libmakepkg path instead of the /usr/share/makepkg default\&.
+.RE
+.PP
\fBPACMAN\fR
.RS 4
The command that will be used to check for missing dependencies and to install and remove packages\&. Pacman\(cqs
@@ -382,6 +397,11 @@ The version of the
\fI$BUILDTOOL\fR
used\&.
.RE
+.PP
+\fBGITFLAGS\fR
+.RS 4
+The options to pass when checking out git sources, replacing the default "\-\-mirror"\&.
+.RE
.SH "CONFIGURATION"
.sp
See \fBmakepkg.conf\fR(5) for more details on configuring makepkg using the \fImakepkg\&.conf\fR file\&.
@@ -515,17 +535,6 @@ Andrew Gregory <andrew\&.gregory\&.8@gmail\&.com>
.sp -1
.IP \(bu 2.3
.\}
-Eli Schwartz <eschwartz@archlinux\&.org>
-.RE
-.sp
-.RS 4
-.ie n \{\
-\h'-04'\(bu\h'+03'\c
-.\}
-.el \{\
-.sp -1
-.IP \(bu 2.3
-.\}
Morgan Adamiec <morganamilo@archlinux\&.org>
.RE
.sp
@@ -608,4 +617,15 @@ Nagy Gabor <ngaba@bibl\&.u\-szeged\&.hu>
Dave Reisner <dreisner@archlinux\&.org>
.RE
.sp
+.RS 4
+.ie n \{\
+\h'-04'\(bu\h'+03'\c
+.\}
+.el \{\
+.sp -1
+.IP \(bu 2.3
+.\}
+Eli Schwartz <eschwartz@archlinux\&.org>
+.RE
+.sp
For additional contributors, use git shortlog \-s on the pacman\&.git repository\&.