summaryrefslogtreecommitdiffstats
path: root/share/mk/install/_.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 19:40:15 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 19:40:15 +0000
commit399644e47874bff147afb19c89228901ac39340e (patch)
tree1c4c0b733f4c16b5783b41bebb19194a9ef62ad1 /share/mk/install/_.mk
parentInitial commit. (diff)
downloadmanpages-399644e47874bff147afb19c89228901ac39340e.tar.xz
manpages-399644e47874bff147afb19c89228901ac39340e.zip
Adding upstream version 6.05.01.upstream/6.05.01
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'share/mk/install/_.mk')
-rw-r--r--share/mk/install/_.mk37
1 files changed, 37 insertions, 0 deletions
diff --git a/share/mk/install/_.mk b/share/mk/install/_.mk
new file mode 100644
index 0000000..751ab97
--- /dev/null
+++ b/share/mk/install/_.mk
@@ -0,0 +1,37 @@
+########################################################################
+# Copyright 2021-2022, Alejandro Colomar <alx@kernel.org>
+# SPDX-License-Identifier: GPL-3.0-or-later
+########################################################################
+
+
+ifndef MAKEFILE_INSTALL_INCLUDED
+MAKEFILE_INSTALL_INCLUDED := 1
+
+
+include $(MAKEFILEDIR)/cmd.mk
+
+
+DESTDIR :=
+prefix := /usr/local
+
+datarootdir := $(prefix)/share
+docdir := $(datarootdir)/doc
+
+
+$(DESTDIR)%/:
+ +$(info INSTALL $@)
+ +$(INSTALL_DIR) $@
+
+%-rm:
+ $(info RM $*)
+ $(RM) $*
+
+
+.PHONY: install
+install: install-man;
+
+.PHONY: uninstall
+uninstall: uninstall-man;
+
+
+endif # include guard