summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0001-fclose.3.patch29
-rw-r--r--debian/patches/0002-getpwent.3.patch51
-rw-r--r--debian/patches/0003-getpwnam.3.patch37
-rw-r--r--debian/patches/0004-nl_langinfo.3.patch21
-rw-r--r--debian/patches/0005-console_codes.4.patch30
-rw-r--r--debian/patches/0006-dir_colors.5.patch29
-rw-r--r--debian/patches/0007-motd.5.patch39
-rw-r--r--debian/patches/0008-nsswitch.conf.5.patch24
-rw-r--r--debian/patches/0009-resolv.conf.5.patch21
-rw-r--r--debian/patches/0010-tzfile.5.patch35
-rw-r--r--debian/patches/0011-man.7.patch20
-rw-r--r--debian/patches/0013-rtnetlink.7.patch20
-rw-r--r--debian/patches/0014-set-proper-installation-path.patch22
-rw-r--r--debian/patches/0015-fix-groff-warning.patch23
-rw-r--r--debian/patches/series14
15 files changed, 415 insertions, 0 deletions
diff --git a/debian/patches/0001-fclose.3.patch b/debian/patches/0001-fclose.3.patch
new file mode 100644
index 0000000..8feaf5b
--- /dev/null
+++ b/debian/patches/0001-fclose.3.patch
@@ -0,0 +1,29 @@
+From: "Dr. Tobias Quathamer" <toddy@debian.org>
+Date: Sat, 6 Feb 2016 01:19:16 +0100
+Subject: fclose.3
+
+---
+ man3/fclose.3 | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/man3/fclose.3 b/man3/fclose.3
+index 3694d54..585b08f 100644
+--- a/man3/fclose.3
++++ b/man3/fclose.3
+@@ -34,6 +34,16 @@ function flushes the stream pointed to by
+ (writing any buffered output data using
+ .BR fflush (3))
+ and closes the underlying file descriptor.
++.\" Reviewed by upstream and rejected, May 2012, Debian#67239
++.PP
++The behaviour of
++.BR fclose ()
++is undefined if the
++.I stream
++parameter is an illegal pointer, or is a descriptor already passed
++to a previous invocation of
++.BR fclose ().
++.\" End of patch
+ .SH RETURN VALUE
+ Upon successful completion, 0 is returned.
+ Otherwise,
diff --git a/debian/patches/0002-getpwent.3.patch b/debian/patches/0002-getpwent.3.patch
new file mode 100644
index 0000000..50c3c83
--- /dev/null
+++ b/debian/patches/0002-getpwent.3.patch
@@ -0,0 +1,51 @@
+From: "Dr. Tobias Quathamer" <toddy@debian.org>
+Date: Sat, 6 Feb 2016 01:20:19 +0100
+Subject: getpwent.3
+
+---
+ man3/getpwent.3 | 20 +++++++++++++++++++-
+ 1 file changed, 19 insertions(+), 1 deletion(-)
+
+diff --git a/man3/getpwent.3 b/man3/getpwent.3
+index c46af20..839c614 100644
+--- a/man3/getpwent.3
++++ b/man3/getpwent.3
+@@ -9,7 +9,8 @@
+ .\" 386BSD man pages
+ .\"
+ .\" Modified Sat Jul 24 19:22:14 1993 by Rik Faith (faith@cs.unc.edu)
+-.\" Modified Mon May 27 21:37:47 1996 by Martin Schulze (joey@linux.de)
++.\" Modified Mon May 27 21:37:47 1996 by Martin Schulze <joey@linux.de>
++.\" Modified Thu Dec 13 21:10:55 2001 by Martin Schulze <joey@infodrom.org>
+ .\"
+ .TH getpwent 3 2023-07-20 "Linux man-pages 6.05.01"
+ .SH NAME
+@@ -79,6 +80,21 @@ struct passwd {
+ };
+ .EE
+ .in
++.\" Next paragraph rejected upstream
++.PP
++When
++.BR shadow (5)
++passwords are enabled (which is default on many GNU/Linux
++installations) the content of
++.I pw_passwd
++is usually not very useful. In such a case most passwords are stored
++in a separate file.
++.PP
++The variable
++.I pw_shell
++may be empty, in which case the system will execute the default shell
++.RB ( /bin/sh )
++for the user.
+ .PP
+ For more information about the fields of this structure, see
+ .BR passwd (5).
+@@ -188,4 +204,6 @@ POSIX.1-2001, SVr4, 4.3BSD.
+ .BR getpwnam (3),
+ .BR getpwuid (3),
+ .BR putpwent (3),
++.\" Next line rejected upstream
++.BR shadow (5),
+ .BR passwd (5)
diff --git a/debian/patches/0003-getpwnam.3.patch b/debian/patches/0003-getpwnam.3.patch
new file mode 100644
index 0000000..83b18cc
--- /dev/null
+++ b/debian/patches/0003-getpwnam.3.patch
@@ -0,0 +1,37 @@
+From: "Dr. Tobias Quathamer" <toddy@debian.org>
+Date: Sat, 6 Feb 2016 01:20:55 +0100
+Subject: getpwnam.3
+
+---
+ man3/getpwnam.3 | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+
+diff --git a/man3/getpwnam.3 b/man3/getpwnam.3
+index 3e6af83..ac7262b 100644
+--- a/man3/getpwnam.3
++++ b/man3/getpwnam.3
+@@ -194,10 +194,18 @@ structure.
+ .TP
+ .B ERANGE
+ Insufficient buffer space supplied.
++.SH NOTE
++The user password database mostly refers to \fI/etc/passwd\fP.
++However, with recent systems it also refers to network wide databases
++using NIS, LDAP and other local files as configured in
++\fI/etc/nsswitch.conf\fP.
+ .SH FILES
+ .TP
+ .I /etc/passwd
+ local password database file
++.TP
++.I /etc/nsswitch.conf
++System Databases and Name Service Switch configuration file
+ .SH ATTRIBUTES
+ For an explanation of the terms used in this section, see
+ .BR attributes (7).
+@@ -348,4 +356,5 @@ main(int argc, char *argv[])
+ .BR getspnam (3),
+ .BR putpwent (3),
+ .BR setpwent (3),
++.BR nsswitch.conf (5),
+ .BR passwd (5)
diff --git a/debian/patches/0004-nl_langinfo.3.patch b/debian/patches/0004-nl_langinfo.3.patch
new file mode 100644
index 0000000..0eba6bf
--- /dev/null
+++ b/debian/patches/0004-nl_langinfo.3.patch
@@ -0,0 +1,21 @@
+From: "Dr. Tobias Quathamer" <toddy@debian.org>
+Date: Sat, 6 Feb 2016 01:21:35 +0100
+Subject: nl_langinfo.3
+
+---
+ man3/nl_langinfo.3 | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/man3/nl_langinfo.3 b/man3/nl_langinfo.3
+index 2726c29..0efe203 100644
+--- a/man3/nl_langinfo.3
++++ b/man3/nl_langinfo.3
+@@ -56,6 +56,8 @@ which was previously created by
+ .BR newlocale (3).
+ Individual and additional elements of the locale categories can
+ be queried.
++.BR setlocale (3)
++needs to be executed with proper arguments before.
+ .PP
+ Examples for the locale elements that can be specified in \fIitem\fP
+ using the constants defined in \fI<langinfo.h>\fP are:
diff --git a/debian/patches/0005-console_codes.4.patch b/debian/patches/0005-console_codes.4.patch
new file mode 100644
index 0000000..4e6afd0
--- /dev/null
+++ b/debian/patches/0005-console_codes.4.patch
@@ -0,0 +1,30 @@
+From: "Dr. Tobias Quathamer" <toddy@debian.org>
+Date: Sat, 6 Feb 2016 01:22:07 +0100
+Subject: console_codes.4
+
+---
+ man4/console_codes.4 | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/man4/console_codes.4 b/man4/console_codes.4
+index e2ac4e8..e67a1f3 100644
+--- a/man4/console_codes.4
++++ b/man4/console_codes.4
+@@ -14,6 +14,7 @@
+ .\" Tiny correction, aeb, 961107.
+ .\"
+ .\" 2006-05-27, Several corrections - Thomas E. Dickey
++.\" Modified Thu Dec 13 23:23:41 2001 by Martin Schulze <joey@infodrom.org>
+ .\"
+ .TH console_codes 4 2023-02-05 "Linux man-pages 6.05.01"
+ .SH NAME
+@@ -716,7 +717,9 @@ ESC m Memory unlock (per HP terminals).
+ ESC n LS2 Invoke the G2 character set.
+ ESC o LS3 Invoke the G3 character set.
+ ESC | LS3R Invoke the G3 character set as GR.
++ Has no visible effect in xterm.
+ ESC } LS2R Invoke the G2 character set as GR.
++ Has no visible effect in xterm.
+ ESC \[ti] LS1R Invoke the G1 character set as GR.
+ .TE
+ .PP
diff --git a/debian/patches/0006-dir_colors.5.patch b/debian/patches/0006-dir_colors.5.patch
new file mode 100644
index 0000000..cb4593b
--- /dev/null
+++ b/debian/patches/0006-dir_colors.5.patch
@@ -0,0 +1,29 @@
+From: "Dr. Tobias Quathamer" <toddy@debian.org>
+Date: Sat, 6 Feb 2016 01:22:32 +0100
+Subject: dir_colors.5
+
+---
+ man5/dir_colors.5 | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/man5/dir_colors.5 b/man5/dir_colors.5
+index ccee252..3084d40 100644
+--- a/man5/dir_colors.5
++++ b/man5/dir_colors.5
+@@ -374,8 +374,16 @@ hash mark as the first character.
+ .TP
+ .I /etc/DIR_COLORS
+ System-wide configuration file.
++.\" Rejected upstream
++(Slackware, SuSE and RedHat only; ignored by GNU
++.BR dircolors (1)
++and thus Debian.)
+ .TP
+ .I \[ti]/.dir_colors
+++.\" Rejected upstream
++(Slackware, SuSE and RedHat only; ignored by GNU
++.BR dircolors (1)
++and thus Debian.)
+ Per-user configuration file.
+ .PP
+ This page describes the
diff --git a/debian/patches/0007-motd.5.patch b/debian/patches/0007-motd.5.patch
new file mode 100644
index 0000000..90a7dc6
--- /dev/null
+++ b/debian/patches/0007-motd.5.patch
@@ -0,0 +1,39 @@
+From: "Dr. Tobias Quathamer" <toddy@debian.org>
+Date: Sat, 6 Feb 2016 01:22:57 +0100
+Subject: motd.5
+
+---
+ man5/motd.5 | 12 ++++++++++++
+ 1 file changed, 12 insertions(+)
+
+diff --git a/man5/motd.5 b/man5/motd.5
+index b506c95..f4c4748 100644
+--- a/man5/motd.5
++++ b/man5/motd.5
+@@ -12,14 +12,26 @@ motd \- message of the day
+ The contents of
+ .I /etc/motd
+ are displayed by
++.\" Patched in Debian, maybe other distribs
++.BR pam_motd (8)
++.\" End of patch
++.\" .BR login (1)
+ .BR login (1)
+ after a successful login but just before it executes the login shell.
+ .PP
+ The abbreviation "motd" stands for "message of the day", and this file
+ has been traditionally used for exactly that (it requires much less disk
+ space than mail to all users).
++.PP
++On Debian GNU/Linux, dynamic content configured at
++.I /etc/pam.d/login
++is also displayed by
++.IR pam_exec .
+ .SH FILES
+ .I /etc/motd
++.br
++.I /etc/pam.d/login
+ .SH SEE ALSO
+ .BR login (1),
+ .BR issue (5)
++.BR pam_motd (8)
diff --git a/debian/patches/0008-nsswitch.conf.5.patch b/debian/patches/0008-nsswitch.conf.5.patch
new file mode 100644
index 0000000..4312e46
--- /dev/null
+++ b/debian/patches/0008-nsswitch.conf.5.patch
@@ -0,0 +1,24 @@
+From: "Dr. Tobias Quathamer" <toddy@debian.org>
+Date: Sat, 6 Feb 2016 01:24:49 +0100
+Subject: nsswitch.conf.5
+
+---
+ man5/nsswitch.conf.5 | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/man5/nsswitch.conf.5 b/man5/nsswitch.conf.5
+index 49b288e..eb690ed 100644
+--- a/man5/nsswitch.conf.5
++++ b/man5/nsswitch.conf.5
+@@ -274,6 +274,11 @@ Include the specified
+ .I user
+ from the NIS passwd/shadow map.
+ .TP
++.BI + user::::::
++Include the specified
++.I user
++from the NIS passwd map, but override with non-empty passwd fields.
++.TP
+ .BI +@ netgroup
+ Include all users in the given
+ .IR netgroup .
diff --git a/debian/patches/0009-resolv.conf.5.patch b/debian/patches/0009-resolv.conf.5.patch
new file mode 100644
index 0000000..29097ea
--- /dev/null
+++ b/debian/patches/0009-resolv.conf.5.patch
@@ -0,0 +1,21 @@
+From: "Dr. Tobias Quathamer" <toddy@debian.org>
+Date: Sat, 6 Feb 2016 01:25:17 +0100
+Subject: resolv.conf.5
+
+---
+ man5/resolv.conf.5 | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/man5/resolv.conf.5 b/man5/resolv.conf.5
+index 1ea918d..a2677b2 100644
+--- a/man5/resolv.conf.5
++++ b/man5/resolv.conf.5
+@@ -249,6 +249,8 @@ this option is deprecated; applications should use
+ .BR getaddrinfo (3),
+ rather than
+ .BR gethostbyname (3).
++.PP
++Some programs behave strangely when this option is turned on.
+ .TP
+ .BR ip6\-bytestring " (since glibc 2.3.4 to glibc 2.24)"
+ Sets
diff --git a/debian/patches/0010-tzfile.5.patch b/debian/patches/0010-tzfile.5.patch
new file mode 100644
index 0000000..0b8acc3
--- /dev/null
+++ b/debian/patches/0010-tzfile.5.patch
@@ -0,0 +1,35 @@
+From: "Dr. Tobias Quathamer" <toddy@debian.org>
+Date: Sat, 6 Feb 2016 01:25:30 +0100
+Subject: tzfile.5
+
+---
+ man5/tzfile.5 | 16 ++++++++++++++++
+ 1 file changed, 16 insertions(+)
+
+diff --git a/man5/tzfile.5 b/man5/tzfile.5
+index 59d9f6b..8bd9e77 100644
+--- a/man5/tzfile.5
++++ b/man5/tzfile.5
+@@ -205,6 +205,22 @@ if either
+ .B tzh_timecnt
+ is zero or the time argument is less than the first transition time recorded
+ in the file.
++.\" http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=122906#47
++.\" Reviewed by upstream and rejected, May 2012
++.SH NOTES
++This manual page documents
++.I <tzfile.h>
++in the glibc source archive, see
++.IR timezone/tzfile.h .
++.PP
++It seems that timezone uses
++.B tzfile
++internally, but glibc refuses to expose it to userspace. This is most
++likely because the standardised functions are more useful and
++portable, and actually documented by glibc. It may only be in glibc
++just to support the non-glibc-maintained timezone data (which is
++maintained by some other entity).
++.\" End of patch
+ .SS Version 2 format
+ For version-2-format timezone files,
+ the above header and data are followed by a second header and data,
diff --git a/debian/patches/0011-man.7.patch b/debian/patches/0011-man.7.patch
new file mode 100644
index 0000000..ddc1474
--- /dev/null
+++ b/debian/patches/0011-man.7.patch
@@ -0,0 +1,20 @@
+From: "Dr. Tobias Quathamer" <toddy@debian.org>
+Date: Sat, 6 Feb 2016 01:27:54 +0100
+Subject: man.7
+
+---
+ man7/man.7 | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/man7/man.7 b/man7/man.7
+index b0788f3..62c9f56 100644
+--- a/man7/man.7
++++ b/man7/man.7
+@@ -500,6 +500,7 @@ is not implemented.
+ .BR lexgrog (1),
+ .BR man (1),
+ .BR man2html (1),
++.BR groff_mdoc (7),
+ .BR whatis (1),
+ .BR groff_man (7),
+ .BR groff_www (7),
diff --git a/debian/patches/0013-rtnetlink.7.patch b/debian/patches/0013-rtnetlink.7.patch
new file mode 100644
index 0000000..5815c1e
--- /dev/null
+++ b/debian/patches/0013-rtnetlink.7.patch
@@ -0,0 +1,20 @@
+From: "Dr. Tobias Quathamer" <toddy@debian.org>
+Date: Sat, 6 Feb 2016 01:28:20 +0100
+Subject: rtnetlink.7
+
+---
+ man7/rtnetlink.7 | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/man7/rtnetlink.7 b/man7/rtnetlink.7
+index 3b6465f..f710bbe 100644
+--- a/man7/rtnetlink.7
++++ b/man7/rtnetlink.7
+@@ -13,6 +13,7 @@ rtnetlink \- Linux routing socket
+ .SH SYNOPSIS
+ .nf
+ .B #include <asm/types.h>
++.B #include <linux/if_link.h>
+ .B #include <linux/netlink.h>
+ .B #include <linux/rtnetlink.h>
+ .B #include <sys/socket.h>
diff --git a/debian/patches/0014-set-proper-installation-path.patch b/debian/patches/0014-set-proper-installation-path.patch
new file mode 100644
index 0000000..3baeb79
--- /dev/null
+++ b/debian/patches/0014-set-proper-installation-path.patch
@@ -0,0 +1,22 @@
+From: Marcos Fouces <marcos@debian.org>
+Date: Thu, 12 May 2022 00:06:17 +0200
+Subject: change installation path in the Makefile.
+
+Forwarded: not-needed
+---
+ share/mk/install/_.mk | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/share/mk/install/_.mk b/share/mk/install/_.mk
+index 751ab97..bbf4ee2 100644
+--- a/share/mk/install/_.mk
++++ b/share/mk/install/_.mk
+@@ -12,7 +12,7 @@ include $(MAKEFILEDIR)/cmd.mk
+
+
+ DESTDIR :=
+-prefix := /usr/local
++prefix := /usr
+
+ datarootdir := $(prefix)/share
+ docdir := $(datarootdir)/doc
diff --git a/debian/patches/0015-fix-groff-warning.patch b/debian/patches/0015-fix-groff-warning.patch
new file mode 100644
index 0000000..b446a05
--- /dev/null
+++ b/debian/patches/0015-fix-groff-warning.patch
@@ -0,0 +1,23 @@
+From: Marcos Fouces <marcos@debian.org>
+Date: Wed, 7 Sep 2022 00:27:23 +0200
+Subject: Mark the glyphs as defined in groff.
+
+This prevents the man viewer from issuing
+warnings about missing characters.
+---
+ man7/glob.7 | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/man7/glob.7 b/man7/glob.7
+index 466701c..c5c4577 100644
+--- a/man7/glob.7
++++ b/man7/glob.7
+@@ -195,7 +195,7 @@ where the string between "\fI[=\fP" and "\fI=]\fP" is any collating
+ element from its equivalence class, as defined for the
+ current locale.
+ For example, "\fI[[=a=]]\fP" might be equivalent
+-to "\fI[a\('a\(`a\(:a\(^a]\fP", that is,
++to "\fI[a\['a]\[`a]\[:a]\[^a]]\fP", that is,
+ to "\fI[a[.a-acute.][.a-grave.][.a-umlaut.][.a-circumflex.]]\fP".
+ .SH SEE ALSO
+ .BR sh (1),
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..98d3eaa
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,14 @@
+0001-fclose.3.patch
+0002-getpwent.3.patch
+0003-getpwnam.3.patch
+0004-nl_langinfo.3.patch
+0005-console_codes.4.patch
+0006-dir_colors.5.patch
+0007-motd.5.patch
+0008-nsswitch.conf.5.patch
+0009-resolv.conf.5.patch
+0010-tzfile.5.patch
+0011-man.7.patch
+0013-rtnetlink.7.patch
+0014-set-proper-installation-path.patch
+0015-fix-groff-warning.patch