summaryrefslogtreecommitdiffstats
path: root/unittest/README.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 12:24:36 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 12:24:36 +0000
commit06eaf7232e9a920468c0f8d74dcf2fe8b555501c (patch)
treee2c7b5777f728320e5b5542b6213fd3591ba51e2 /unittest/README.txt
parentInitial commit. (diff)
downloadmariadb-06eaf7232e9a920468c0f8d74dcf2fe8b555501c.tar.xz
mariadb-06eaf7232e9a920468c0f8d74dcf2fe8b555501c.zip
Adding upstream version 1:10.11.6.upstream/1%10.11.6
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'unittest/README.txt')
-rw-r--r--unittest/README.txt53
1 files changed, 53 insertions, 0 deletions
diff --git a/unittest/README.txt b/unittest/README.txt
new file mode 100644
index 00000000..ea94a505
--- /dev/null
+++ b/unittest/README.txt
@@ -0,0 +1,53 @@
+
+Unit tests directory structure
+------------------------------
+
+This is the current structure of the unit tests. More directories
+will be added over time.
+
+mytap Source for the MyTAP library
+mysys Tests for mysys components
+ bitmap-t.c Unit test for MY_BITMAP
+ base64-t.c Unit test for base64 encoding functions
+examples Example unit tests.
+ core-t.c Example of raising a signal in the middle of the test
+ THIS TEST WILL STOP ALL FURTHER TESTING!
+ simple-t.c Example of a standard TAP unit test
+ skip-t.c Example where some test points are skipped
+ skip_all-t.c Example of a test where the entire test is skipped
+ todo-t.c Example where test contain test points that are TODO
+ no_plan-t.c Example of a test with no plan (avoid this)
+
+
+Executing unit tests
+--------------------
+
+To make and execute all unit tests in the directory:
+
+ make test
+
+Observe that the tests in the examples/ directory are just various
+examples of tests and are not expected to pass.
+
+
+Adding unit tests
+-----------------
+
+Add a file with a name of the format "foo-t.c" to the appropriate
+directory and add the following to the Makefile.am in that directory
+(where ... denotes stuff already there):
+
+ noinst_PROGRAMS = ... foo-t
+
+Note, it's important to have "-t" at the end of the filename, otherwise the
+test won't be executed by 'make test' !
+
+
+Documentation
+-------------
+
+The generated documentation is temporarily placed at:
+
+ http://www.kindahl.net/mytap/doc/
+
+I will move it to a better place once I figure out where and how.