summaryrefslogtreecommitdiffstats
path: root/plugin/feedback
diff options
context:
space:
mode:
Diffstat (limited to 'plugin/feedback')
-rw-r--r--plugin/feedback/CMakeLists.txt2
-rw-r--r--plugin/feedback/sender_thread.cc2
2 files changed, 2 insertions, 2 deletions
diff --git a/plugin/feedback/CMakeLists.txt b/plugin/feedback/CMakeLists.txt
index 2103250e..fc35cbad 100644
--- a/plugin/feedback/CMakeLists.txt
+++ b/plugin/feedback/CMakeLists.txt
@@ -1,5 +1,5 @@
INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/sql
- ${PCRE_INCLUDES}
+ ${PCRE_INCLUDE_DIRS}
${SSL_INCLUDE_DIRS})
SET(FEEDBACK_SOURCES feedback.cc sender_thread.cc
diff --git a/plugin/feedback/sender_thread.cc b/plugin/feedback/sender_thread.cc
index 6b5be475..cc29e57f 100644
--- a/plugin/feedback/sender_thread.cc
+++ b/plugin/feedback/sender_thread.cc
@@ -96,8 +96,8 @@ static int prepare_for_fill(TABLE_LIST *tables)
thd->mysys_var->current_cond= &sleep_condition;
thd->mysys_var->current_mutex= &sleep_mutex;
+ thd->mark_connection_idle();
thd->proc_info="feedback";
- thd->set_command(COM_SLEEP);
thd->system_thread= SYSTEM_THREAD_EVENT_WORKER; // whatever
thd->set_time();
thd->init_for_queries();