summaryrefslogtreecommitdiffstats
path: root/plugin/provider_snappy/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugin/provider_snappy/CMakeLists.txt')
-rw-r--r--plugin/provider_snappy/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/plugin/provider_snappy/CMakeLists.txt b/plugin/provider_snappy/CMakeLists.txt
new file mode 100644
index 00000000..d963029d
--- /dev/null
+++ b/plugin/provider_snappy/CMakeLists.txt
@@ -0,0 +1,15 @@
+FIND_PACKAGE(Snappy)
+
+SET(CPACK_RPM_provider-snappy_PACKAGE_SUMMARY "Snappy compression support in the server and storage engines" PARENT_SCOPE)
+SET(CPACK_RPM_provider-snappy_PACKAGE_DESCRIPTION "Snappy compression support in the server and storage engines" PARENT_SCOPE)
+
+IF (SNAPPY_FOUND)
+ GET_PROPERTY(dirs DIRECTORY PROPERTY INCLUDE_DIRECTORIES)
+ LIST(REMOVE_ITEM dirs ${CMAKE_SOURCE_DIR}/include/providers)
+ SET_PROPERTY(DIRECTORY PROPERTY INCLUDE_DIRECTORIES "${dirs}")
+
+ INCLUDE_DIRECTORIES(${SNAPPY_INCLUDE_DIRS})
+
+ MYSQL_ADD_PLUGIN(provider_snappy plugin.c COMPONENT provider-snappy
+ LINK_LIBRARIES ${SNAPPY_LIBRARIES} CONFIG provider_snappy.cnf)
+ENDIF()