summaryrefslogtreecommitdiffstats
path: root/storage/archive/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'storage/archive/CMakeLists.txt')
-rw-r--r--storage/archive/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/storage/archive/CMakeLists.txt b/storage/archive/CMakeLists.txt
new file mode 100644
index 00000000..5b6818fc
--- /dev/null
+++ b/storage/archive/CMakeLists.txt
@@ -0,0 +1,18 @@
+# Copyright (c) 2006, 2010, Oracle and/or its affiliates. All rights reserved.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1335 USA
+
+SET(ARCHIVE_SOURCES azio.c ha_archive.cc ha_archive.h)
+MYSQL_ADD_PLUGIN(archive ${ARCHIVE_SOURCES} STORAGE_ENGINE LINK_LIBRARIES ${ZLIB_LIBRARY})
+