summaryrefslogtreecommitdiffstats
path: root/storage/heap/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'storage/heap/CMakeLists.txt')
-rw-r--r--storage/heap/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/storage/heap/CMakeLists.txt b/storage/heap/CMakeLists.txt
new file mode 100644
index 00000000..a26124d0
--- /dev/null
+++ b/storage/heap/CMakeLists.txt
@@ -0,0 +1,35 @@
+# Copyright (c) 2006, 2010, Oracle and/or its affiliates. All rights reserved.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1335 USA
+
+SET(HEAP_SOURCES _check.c _rectest.c hp_block.c hp_clear.c hp_close.c hp_create.c
+ ha_heap.cc
+ hp_delete.c hp_extra.c hp_hash.c hp_info.c hp_open.c hp_panic.c
+ hp_rename.c hp_rfirst.c hp_rkey.c hp_rlast.c hp_rnext.c hp_rprev.c
+ hp_rrnd.c hp_rsame.c hp_scan.c hp_static.c hp_update.c hp_write.c)
+
+MYSQL_ADD_PLUGIN(heap ${HEAP_SOURCES} STORAGE_ENGINE MANDATORY RECOMPILE_FOR_EMBEDDED)
+
+IF(CMAKE_SYSTEM_NAME MATCHES AIX AND CMAKE_BUILD_TYPE STREQUAL "DEBUG")
+ # Workaround linker bug on AIX
+ SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,-berok")
+ENDIF()
+
+IF(WITH_UNIT_TESTS)
+ ADD_EXECUTABLE(hp_test1 hp_test1.c)
+ TARGET_LINK_LIBRARIES(hp_test1 heap mysys dbug strings)
+
+ ADD_EXECUTABLE(hp_test2 hp_test2.c)
+ TARGET_LINK_LIBRARIES(hp_test2 heap mysys dbug strings)
+ENDIF() \ No newline at end of file