summaryrefslogtreecommitdiffstats
path: root/wsrep-lib/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'wsrep-lib/src/CMakeLists.txt')
-rw-r--r--wsrep-lib/src/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/wsrep-lib/src/CMakeLists.txt b/wsrep-lib/src/CMakeLists.txt
new file mode 100644
index 00000000..85524cea
--- /dev/null
+++ b/wsrep-lib/src/CMakeLists.txt
@@ -0,0 +1,31 @@
+#
+# Copyright (C) 2018 Codership Oy <info@codership.com>
+#
+
+add_library(wsrep-lib
+ allowlist_service_v1.cpp
+ client_state.cpp
+ config_service_v1.cpp
+ event_service_v1.cpp
+ exception.cpp
+ gtid.cpp
+ id.cpp
+ key.cpp
+ logger.cpp
+ provider.cpp
+ provider_options.cpp
+ reporter.cpp
+ seqno.cpp
+ server_state.cpp
+ sr_key_set.cpp
+ streaming_context.cpp
+ thread.cpp
+ thread_service_v1.cpp
+ tls_service_v1.cpp
+ transaction.cpp
+ uuid.cpp
+ view.cpp
+ wsrep_provider_v26.cpp
+ xid.cpp
+ )
+target_link_libraries(wsrep-lib wsrep_api_v26 pthread ${WSREP_LIB_LIBDL})