summaryrefslogtreecommitdiffstats
path: root/wsrep-lib/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'wsrep-lib/test/CMakeLists.txt')
-rw-r--r--wsrep-lib/test/CMakeLists.txt47
1 files changed, 47 insertions, 0 deletions
diff --git a/wsrep-lib/test/CMakeLists.txt b/wsrep-lib/test/CMakeLists.txt
new file mode 100644
index 00000000..366cc478
--- /dev/null
+++ b/wsrep-lib/test/CMakeLists.txt
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2018 Codership Oy <info@codership.com>
+#
+
+
+set(TEST_SOURCES
+ mock_client_state.cpp
+ mock_high_priority_service.cpp
+ mock_storage_service.cpp
+ test_utils.cpp
+ buffer_test.cpp
+ gtid_test.cpp
+ id_test.cpp
+ nbo_test.cpp
+ rsu_test.cpp
+ server_context_test.cpp
+ toi_test.cpp
+ transaction_test.cpp
+ transaction_test_2pc.cpp
+ transaction_test_xa.cpp
+ view_test.cpp
+ xid_test.cpp
+ wsrep-lib_test.cpp
+ )
+
+if (WSREP_LIB_WITH_UNIT_TESTS_EXTRA)
+ set(TEST_SOURCES ${TEST_SOURCES}
+ reporter_test.cpp
+ )
+endif()
+
+add_executable(wsrep-lib_test ${TEST_SOURCES})
+
+target_link_libraries(wsrep-lib_test wsrep-lib)
+
+add_test(NAME wsrep-lib_test
+ COMMAND wsrep-lib_test)
+
+if (WSREP_LIB_WITH_AUTO_TEST)
+ set(UNIT_TEST wsrep-lib_test)
+ add_custom_command(
+ TARGET ${UNIT_TEST}
+ COMMENT "Run tests"
+ POST_BUILD
+ COMMAND ${UNIT_TEST}
+ )
+endif()