summaryrefslogtreecommitdiffstats
path: root/lib/tty/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:22:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:22:03 +0000
commitffccd5b2b05243e7976db80f90f453dccfae9886 (patch)
tree39a43152d27f7390d8f7a6fb276fa6887f87c6e8 /lib/tty/Makefile.am
parentInitial commit. (diff)
downloadmc-upstream/3%4.8.30.tar.xz
mc-upstream/3%4.8.30.zip
Adding upstream version 3:4.8.30.upstream/3%4.8.30
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'lib/tty/Makefile.am')
-rw-r--r--lib/tty/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/lib/tty/Makefile.am b/lib/tty/Makefile.am
new file mode 100644
index 0000000..d4260fe
--- /dev/null
+++ b/lib/tty/Makefile.am
@@ -0,0 +1,36 @@
+
+noinst_LTLIBRARIES = libmctty.la
+
+if USE_SCREEN_SLANG
+ TTY_SCREEN_SRC = \
+ color-slang.c color-slang.h \
+ tty-slang.c tty-slang.h
+else
+ TTY_SCREEN_SRC = \
+ color-ncurses.c \
+ tty-ncurses.c tty-ncurses.h
+endif
+
+TTY_SRC = \
+ color-internal.c color-internal.h \
+ color.c color.h \
+ key.c key.h keyxdef.c \
+ mouse.c mouse.h \
+ tty-internal.c tty-internal.h \
+ tty.c tty.h \
+ win.c win.h
+
+if HAVE_TEXTMODE_X11_SUPPORT
+TTY_SRC += x11conn.c x11conn.h
+endif
+
+libmctty_la_SOURCES = $(TTY_SRC) $(TTY_SCREEN_SRC)
+
+AM_CPPFLAGS = -I$(top_srcdir)
+
+if HAVE_GMODULE
+AM_CPPFLAGS += $(GMODULE_CFLAGS)
+else
+AM_CPPFLAGS += $(GLIB_CFLAGS)
+endif
+