summaryrefslogtreecommitdiffstats
path: root/src/filemanager/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:22:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:22:03 +0000
commitffccd5b2b05243e7976db80f90f453dccfae9886 (patch)
tree39a43152d27f7390d8f7a6fb276fa6887f87c6e8 /src/filemanager/Makefile.am
parentInitial commit. (diff)
downloadmc-ffccd5b2b05243e7976db80f90f453dccfae9886.tar.xz
mc-ffccd5b2b05243e7976db80f90f453dccfae9886.zip
Adding upstream version 3:4.8.30.upstream/3%4.8.30
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/filemanager/Makefile.am')
-rw-r--r--src/filemanager/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/src/filemanager/Makefile.am b/src/filemanager/Makefile.am
new file mode 100644
index 0000000..534d8dc
--- /dev/null
+++ b/src/filemanager/Makefile.am
@@ -0,0 +1,40 @@
+
+noinst_LTLIBRARIES = libmcfilemanager.la
+
+libmcfilemanager_la_SOURCES = \
+ achown.c \
+ boxes.c boxes.h \
+ cd.c cd.h \
+ chmod.c \
+ chown.c \
+ cmd.c cmd.h \
+ command.c command.h \
+ dir.c dir.h \
+ ext.c ext.h \
+ file.c file.h \
+ filegui.c filegui.h \
+ filemanager.h filemanager.c \
+ filenot.c filenot.h \
+ fileopctx.c fileopctx.h \
+ find.c \
+ hotlist.c hotlist.h \
+ info.c info.h \
+ ioblksize.h \
+ layout.c layout.h \
+ mountlist.c mountlist.h \
+ panelize.c panelize.h \
+ panel.c panel.h \
+ tree.c tree.h \
+ treestore.c treestore.h
+
+# Unmaintained, unsupported, etc
+# listmode.c listmode.h
+
+AM_CPPFLAGS = -I$(top_srcdir) $(GLIB_CFLAGS)
+
+if ENABLE_EXT2FS_ATTR
+libmcfilemanager_la_SOURCES += \
+ chattr.c
+
+AM_CPPFLAGS += @EXT2FS_CFLAGS@ @E2P_CFLAGS@
+endif