summaryrefslogtreecommitdiffstats
path: root/tests/lib/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:22:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:22:03 +0000
commitffccd5b2b05243e7976db80f90f453dccfae9886 (patch)
tree39a43152d27f7390d8f7a6fb276fa6887f87c6e8 /tests/lib/Makefile.am
parentInitial commit. (diff)
downloadmc-upstream/3%4.8.30.tar.xz
mc-upstream/3%4.8.30.zip
Adding upstream version 3:4.8.30.upstream/3%4.8.30
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/lib/Makefile.am')
-rw-r--r--tests/lib/Makefile.am65
1 files changed, 65 insertions, 0 deletions
diff --git a/tests/lib/Makefile.am b/tests/lib/Makefile.am
new file mode 100644
index 0000000..56585f9
--- /dev/null
+++ b/tests/lib/Makefile.am
@@ -0,0 +1,65 @@
+PACKAGE_STRING = "/lib"
+
+SUBDIRS = . mcconfig search strutil vfs widget
+
+AM_CPPFLAGS = $(GLIB_CFLAGS) -I$(top_srcdir) @CHECK_CFLAGS@
+
+AM_LDFLAGS = @TESTS_LDFLAGS@
+
+LIBS = @CHECK_LIBS@ \
+ $(top_builddir)/lib/libmc.la
+
+if ENABLE_MCLIB
+LIBS += $(GLIB_LIBS) \
+ @E2P_LIBS@
+endif
+
+EXTRA_DIST = utilunix__my_system-common.c
+
+TESTS = \
+ library_independ \
+ mc_build_filename \
+ name_quote \
+ serialize \
+ utilunix__mc_pstream_get_string \
+ utilunix__my_system_fork_fail \
+ utilunix__my_system_fork_child_shell \
+ utilunix__my_system_fork_child \
+ x_basename
+
+if CHARSET
+TESTS += mc_realpath
+endif
+
+check_PROGRAMS = $(TESTS)
+
+library_independ_SOURCES = \
+ library_independ.c
+
+mc_build_filename_SOURCES = \
+ mc_build_filename.c
+
+mc_realpath_SOURCES = \
+ mc_realpath.c
+
+name_quote_SOURCES = \
+ name_quote.c
+
+serialize_SOURCES = \
+ serialize.c
+
+utilunix__mc_pstream_get_string_SOURCES = \
+ utilunix__mc_pstream_get_string.c
+
+utilunix__my_system_fork_fail_SOURCES = \
+ utilunix__my_system-fork_fail.c
+
+utilunix__my_system_fork_child_shell_SOURCES = \
+ utilunix__my_system-fork_child_shell.c
+
+utilunix__my_system_fork_child_SOURCES = \
+ utilunix__my_system-fork_child.c
+
+x_basename_SOURCES = \
+ x_basename.c
+