summaryrefslogtreecommitdiffstats
path: root/tests/lib/strutil/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:22:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:22:03 +0000
commitffccd5b2b05243e7976db80f90f453dccfae9886 (patch)
tree39a43152d27f7390d8f7a6fb276fa6887f87c6e8 /tests/lib/strutil/Makefile.am
parentInitial commit. (diff)
downloadmc-ffccd5b2b05243e7976db80f90f453dccfae9886.tar.xz
mc-ffccd5b2b05243e7976db80f90f453dccfae9886.zip
Adding upstream version 3:4.8.30.upstream/3%4.8.30
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/lib/strutil/Makefile.am')
-rw-r--r--tests/lib/strutil/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/tests/lib/strutil/Makefile.am b/tests/lib/strutil/Makefile.am
new file mode 100644
index 0000000..7a77395
--- /dev/null
+++ b/tests/lib/strutil/Makefile.am
@@ -0,0 +1,33 @@
+PACKAGE_STRING = "/lib/strutil"
+
+AM_CPPFLAGS = \
+ $(GLIB_CFLAGS) \
+ -I$(top_srcdir) \
+ @CHECK_CFLAGS@
+
+LIBS = @CHECK_LIBS@ \
+ $(top_builddir)/lib/libmc.la
+
+if ENABLE_MCLIB
+LIBS += $(GLIB_LIBS)
+endif
+
+TESTS = \
+ parse_integer \
+ str_replace_all \
+ str_verscmp \
+ filevercmp
+
+check_PROGRAMS = $(TESTS)
+
+parse_integer_SOURCES = \
+ parse_integer.c
+
+str_replace_all_SOURCES = \
+ str_replace_all.c
+
+str_verscmp_SOURCES = \
+ str_verscmp.c
+
+filevercmp_SOURCES = \
+ filevercmp.c