summaryrefslogtreecommitdiffstats
path: root/tests/src/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:22:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:22:03 +0000
commitffccd5b2b05243e7976db80f90f453dccfae9886 (patch)
tree39a43152d27f7390d8f7a6fb276fa6887f87c6e8 /tests/src/Makefile.am
parentInitial commit. (diff)
downloadmc-0acba638a84ac029b0ce3ee33c0f8b7d9f3fa027.tar.xz
mc-0acba638a84ac029b0ce3ee33c0f8b7d9f3fa027.zip
Adding upstream version 3:4.8.30.upstream/3%4.8.30
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/src/Makefile.am')
-rw-r--r--tests/src/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/tests/src/Makefile.am b/tests/src/Makefile.am
new file mode 100644
index 0000000..798f4f3
--- /dev/null
+++ b/tests/src/Makefile.am
@@ -0,0 +1,44 @@
+PACKAGE_STRING = "/src"
+
+SUBDIRS = . filemanager vfs
+
+if USE_INTERNAL_EDIT
+SUBDIRS += editor
+endif
+
+AM_CPPFLAGS = \
+ $(GLIB_CFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/lib/vfs \
+ @CHECK_CFLAGS@
+
+AM_LDFLAGS = @TESTS_LDFLAGS@
+
+LIBS = @CHECK_LIBS@ \
+ $(top_builddir)/src/libinternal.la \
+ $(top_builddir)/lib/libmc.la
+
+if ENABLE_MCLIB
+LIBS += $(GLIB_LIBS)
+endif
+
+EXTRA_DIST = execute__common.c
+
+TESTS = \
+ execute__execute_with_vfs_arg \
+ execute__execute_external_editor_or_viewer \
+ execute__execute_get_external_cmd_opts_from_config
+
+check_PROGRAMS = $(TESTS)
+
+execute__execute_with_vfs_arg_SOURCES = \
+ execute__execute_with_vfs_arg.c
+
+
+execute__execute_external_editor_or_viewer_SOURCES = \
+ execute__execute_external_editor_or_viewer.c
+
+
+execute__execute_get_external_cmd_opts_from_config_SOURCES = \
+ execute__execute_get_external_cmd_opts_from_config.c
+