summaryrefslogtreecommitdiffstats
path: root/src/editor/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/editor/Makefile.am')
-rw-r--r--src/editor/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/editor/Makefile.am b/src/editor/Makefile.am
new file mode 100644
index 0000000..304cb35
--- /dev/null
+++ b/src/editor/Makefile.am
@@ -0,0 +1,33 @@
+EXTRA_DIST =
+
+if USE_INTERNAL_EDIT
+noinst_LTLIBRARIES = libedit.la
+else
+noinst_LTLIBRARIES =
+endif
+
+libedit_la_SOURCES = \
+ bookmark.c \
+ edit-impl.h \
+ edit.c edit.h \
+ editcomplete.c editcomplete.h \
+ editbuffer.c editbuffer.h \
+ editcmd.c \
+ editdraw.c \
+ editmacros.c editmacros.h \
+ editmenu.c \
+ editoptions.c \
+ editsearch.c editsearch.h \
+ editwidget.c editwidget.h \
+ etags.c etags.h \
+ format.c \
+ syntax.c
+
+if USE_ASPELL
+if HAVE_GMODULE
+libedit_la_SOURCES += \
+ spell.c spell.h
+endif
+endif
+
+AM_CPPFLAGS = $(GLIB_CFLAGS) -I$(top_srcdir)