summaryrefslogtreecommitdiffstats
path: root/tests/lib/search/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/lib/search/Makefile.am')
-rw-r--r--tests/lib/search/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/tests/lib/search/Makefile.am b/tests/lib/search/Makefile.am
new file mode 100644
index 0000000..c3296ab
--- /dev/null
+++ b/tests/lib/search/Makefile.am
@@ -0,0 +1,42 @@
+PACKAGE_STRING = "/lib/search"
+
+AM_CPPFLAGS = \
+ $(GLIB_CFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/lib/search \
+ @CHECK_CFLAGS@
+
+LIBS = @CHECK_LIBS@ \
+ $(top_builddir)/lib/libmc.la
+
+if ENABLE_MCLIB
+LIBS += $(GLIB_LIBS)
+endif
+
+TESTS = \
+ glob_prepare_replace_str \
+ glob_translate_to_regex \
+ hex_translate_to_regex \
+ regex_replace_esc_seq \
+ regex_process_escape_sequence \
+ translate_replace_glob_to_regex
+
+check_PROGRAMS = $(TESTS)
+
+glob_prepare_replace_str_SOURCES = \
+ glob_prepare_replace_str.c
+
+regex_replace_esc_seq_SOURCES = \
+ regex_replace_esc_seq.c
+
+regex_process_escape_sequence_SOURCES = \
+ regex_process_escape_sequence.c
+
+translate_replace_glob_to_regex_SOURCES = \
+ translate_replace_glob_to_regex.c
+
+glob_translate_to_regex_SOURCES = \
+ glob_translate_to_regex.c
+
+hex_translate_to_regex_SOURCES = \
+ hex_translate_to_regex.c