summaryrefslogtreecommitdiffstats
path: root/tests/lib/widget/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/lib/widget/Makefile.am')
-rw-r--r--tests/lib/widget/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/tests/lib/widget/Makefile.am b/tests/lib/widget/Makefile.am
new file mode 100644
index 0000000..0cf0c75
--- /dev/null
+++ b/tests/lib/widget/Makefile.am
@@ -0,0 +1,40 @@
+PACKAGE_STRING = "/lib/widget"
+
+AM_CPPFLAGS = \
+ $(GLIB_CFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/lib/vfs \
+ @CHECK_CFLAGS@
+
+AM_LDFLAGS = @TESTS_LDFLAGS@
+
+LIBS = @CHECK_LIBS@ \
+ $(top_builddir)/lib/libmc.la
+
+if ENABLE_MCLIB
+LIBS += $(GLIB_LIBS)
+endif
+
+TESTS = \
+ complete_engine \
+ hotkey_equal \
+ group_init_destroy \
+ widget_find_by_id \
+ widget_make_global_local
+
+check_PROGRAMS = $(TESTS)
+
+complete_engine_SOURCES = \
+ complete_engine.c
+
+hotkey_equal_SOURCES = \
+ hotkey_equal.c
+
+group_init_destroy_SOURCES = \
+ group_init_destroy.c
+
+widget_find_by_id_SOURCES = \
+ widget_find_by_id.c
+
+widget_make_global_local_SOURCES = \
+ widget_make_global_local.c