summaryrefslogtreecommitdiffstats
path: root/tests/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/src/Makefile.am')
-rw-r--r--tests/src/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/tests/src/Makefile.am b/tests/src/Makefile.am
new file mode 100644
index 0000000..798f4f3
--- /dev/null
+++ b/tests/src/Makefile.am
@@ -0,0 +1,44 @@
+PACKAGE_STRING = "/src"
+
+SUBDIRS = . filemanager vfs
+
+if USE_INTERNAL_EDIT
+SUBDIRS += editor
+endif
+
+AM_CPPFLAGS = \
+ $(GLIB_CFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/lib/vfs \
+ @CHECK_CFLAGS@
+
+AM_LDFLAGS = @TESTS_LDFLAGS@
+
+LIBS = @CHECK_LIBS@ \
+ $(top_builddir)/src/libinternal.la \
+ $(top_builddir)/lib/libmc.la
+
+if ENABLE_MCLIB
+LIBS += $(GLIB_LIBS)
+endif
+
+EXTRA_DIST = execute__common.c
+
+TESTS = \
+ execute__execute_with_vfs_arg \
+ execute__execute_external_editor_or_viewer \
+ execute__execute_get_external_cmd_opts_from_config
+
+check_PROGRAMS = $(TESTS)
+
+execute__execute_with_vfs_arg_SOURCES = \
+ execute__execute_with_vfs_arg.c
+
+
+execute__execute_external_editor_or_viewer_SOURCES = \
+ execute__execute_external_editor_or_viewer.c
+
+
+execute__execute_get_external_cmd_opts_from_config_SOURCES = \
+ execute__execute_get_external_cmd_opts_from_config.c
+