summaryrefslogtreecommitdiffstats
path: root/tests/src/editor/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/src/editor/Makefile.am')
-rw-r--r--tests/src/editor/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/tests/src/editor/Makefile.am b/tests/src/editor/Makefile.am
new file mode 100644
index 0000000..cf89d33
--- /dev/null
+++ b/tests/src/editor/Makefile.am
@@ -0,0 +1,28 @@
+PACKAGE_STRING = "/src/editor"
+
+AM_CPPFLAGS = \
+ -DTEST_SHARE_DIR=\"$(abs_srcdir)\" \
+ $(GLIB_CFLAGS) \
+ -I$(top_srcdir) \
+ @CHECK_CFLAGS@
+
+AM_LDFLAGS = @TESTS_LDFLAGS@
+
+LIBS = @CHECK_LIBS@ \
+ $(top_builddir)/src/libinternal.la \
+ $(top_builddir)/lib/libmc.la
+
+if ENABLE_MCLIB
+LIBS += $(GLIB_LIBS)
+endif
+
+EXTRA_DIST = mc.charsets test-data.txt.in
+
+TESTS = \
+ edit_complete_word_cmd
+
+check_PROGRAMS = $(TESTS)
+
+edit_complete_word_cmd_SOURCES = \
+ edit_complete_word_cmd.c
+