summaryrefslogtreecommitdiffstats
path: root/tests/src/vfs/ftpfs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/src/vfs/ftpfs/Makefile.am')
-rw-r--r--tests/src/vfs/ftpfs/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/tests/src/vfs/ftpfs/Makefile.am b/tests/src/vfs/ftpfs/Makefile.am
new file mode 100644
index 0000000..294604b
--- /dev/null
+++ b/tests/src/vfs/ftpfs/Makefile.am
@@ -0,0 +1,32 @@
+PACKAGE_STRING = "/src/vfs/ftpfs"
+
+AM_CPPFLAGS = \
+ $(GLIB_CFLAGS) \
+ -DTEST_DATA_DIR=\"$(abs_srcdir)/data\" \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/lib/vfs \
+ @CHECK_CFLAGS@
+
+AM_LDFLAGS = @TESTS_LDFLAGS@
+
+LIBS = @CHECK_LIBS@ \
+ $(top_builddir)/src/libinternal.la \
+ $(top_builddir)/lib/libmc.la
+
+if ENABLE_MCLIB
+LIBS += $(GLIB_LIBS)
+endif
+
+EXTRA_DIST = \
+ data/aix_list.input \
+ data/aix_list.output \
+ data/ms_list.input \
+ data/ms_list.output
+
+TESTS = \
+ ftpfs_parse_long_list
+
+check_PROGRAMS = $(TESTS)
+
+ftpfs_parse_long_list_SOURCES = \
+ ftpfs_parse_long_list.c