summaryrefslogtreecommitdiffstats
path: root/debian/patches/debian/0007-no-Werror.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/debian/0007-no-Werror.patch')
-rw-r--r--debian/patches/debian/0007-no-Werror.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/patches/debian/0007-no-Werror.patch b/debian/patches/debian/0007-no-Werror.patch
new file mode 100644
index 0000000..f7466a5
--- /dev/null
+++ b/debian/patches/debian/0007-no-Werror.patch
@@ -0,0 +1,18 @@
+Author: Martin F. Krafft <madduck@debian.org>
+Description: Remove -Werror from compiler flags.
+ -Werror seems like a bad idea on released/packaged code because a toolchain
+ update (introducing new warnings) could break the build. We'll let upstream
+ use it to beautify the code, but remove it for out builds.
+
+diff -Naurp mdadm.orig/Makefile mdadm/Makefile
+--- mdadm.orig/Makefile
++++ mdadm/Makefile
+@@ -50,7 +50,7 @@ ifeq ($(origin CC),default)
+ CC := $(CROSS_COMPILE)gcc
+ endif
+ CXFLAGS ?= -ggdb
+-CWFLAGS ?= -Wall -Werror -Wstrict-prototypes -Wextra -Wno-unused-parameter -Wformat -Wformat-security -Werror=format-security -fstack-protector-strong -fPIE -Warray-bounds
++CWFLAGS ?= -Wall -Wstrict-prototypes -Wextra -Wno-unused-parameter -Wformat -Wformat-security -Werror=format-security -fstack-protector-strong -fPIE -Warray-bounds
+ ifdef WARN_UNUSED
+ CWFLAGS += -Wp -O3
+ endif