summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:46:17 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:46:17 +0000
commit85adc697d2ec2a379ce6d721f0419ae5df3abdb6 (patch)
tree265f329bc4544c6f11a27ac3fd6022f593a10c11 /test/Makefile.am
parentInitial commit. (diff)
downloadmdds-85adc697d2ec2a379ce6d721f0419ae5df3abdb6.tar.xz
mdds-85adc697d2ec2a379ce6d721f0419ae5df3abdb6.zip
Adding upstream version 2.1.1.upstream/2.1.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--test/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 0000000..b7a72de
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,28 @@
+SUBDIRS = \
+ gdb \
+ flat_segment_tree \
+ include \
+ multi_type_vector \
+ multi_type_matrix \
+ point_quad_tree \
+ rtree \
+ segment_tree \
+ sorted_string_map \
+ trie_map
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/test/include \
+ $(CXXFLAGS_UNITTESTS)
+
+check_PROGRAMS = \
+ ref-pair-test
+
+ref_pair_test_SOURCES = \
+ ref_pair_test.cpp \
+ test_global.cpp
+
+TESTS = \
+ ref-pair-test
+
+@VALGRIND_CHECK_RULES@