summaryrefslogtreecommitdiffstats
path: root/test/rtree/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:46:17 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:46:17 +0000
commit85adc697d2ec2a379ce6d721f0419ae5df3abdb6 (patch)
tree265f329bc4544c6f11a27ac3fd6022f593a10c11 /test/rtree/Makefile.am
parentInitial commit. (diff)
downloadmdds-85adc697d2ec2a379ce6d721f0419ae5df3abdb6.tar.xz
mdds-85adc697d2ec2a379ce6d721f0419ae5df3abdb6.zip
Adding upstream version 2.1.1.upstream/2.1.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test/rtree/Makefile.am')
-rw-r--r--test/rtree/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/test/rtree/Makefile.am b/test/rtree/Makefile.am
new file mode 100644
index 0000000..a664104
--- /dev/null
+++ b/test/rtree/Makefile.am
@@ -0,0 +1,41 @@
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/test/include \
+ $(CXXFLAGS_UNITTESTS)
+
+DISTCLEANFILES = \
+ rtree-test-*.obj \
+ rtree-test-*.svg
+
+check_PROGRAMS = test-main test-bulkload
+
+test_main_SOURCES = \
+ test_main.cpp \
+ $(top_srcdir)/test/test_global.cpp
+
+test_main_SOURCES = \
+ test_basic.cpp \
+ test_copy.cpp \
+ test_directory_node_split.cpp \
+ test_erase_directories.cpp \
+ test_exact_search_by_extent.cpp \
+ test_exact_search_by_point.cpp \
+ test_forced_reinsertion.cpp \
+ test_geometry.cpp \
+ test_intersection.cpp \
+ test_main.cpp \
+ test_move.cpp \
+ test_node_split.cpp \
+ test_point_objects.cpp \
+ test_square_distance.cpp \
+ $(top_srcdir)/test/test_global.cpp
+
+test_bulkload_SOURCES = \
+ test_bulkload_main.cpp \
+ $(top_srcdir)/test/test_global.cpp
+
+EXTRA_DIST = test_global_rtree.hpp
+
+TESTS = test-main test-bulkload
+
+@VALGRIND_CHECK_RULES@