summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 11:48:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 11:48:22 +0000
commit7373ce3d6988706388f136e1c06afd20a3e8d5be (patch)
treee9ae5af7d102667e5706187646db45de8238e8c4 /Makefile.am
parentInitial commit. (diff)
downloadmonitoring-plugins-7373ce3d6988706388f136e1c06afd20a3e8d5be.tar.xz
monitoring-plugins-7373ce3d6988706388f136e1c06afd20a3e8d5be.zip
Adding upstream version 2.3.5.upstream/2.3.5upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am63
1 files changed, 63 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..fe9c564
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,63 @@
+## Process this file with automake to produce Makefile.in
+
+SUBDIRS = gl tap lib plugins plugins-scripts plugins-root po @PERLMODS_DIR@
+
+EXTRA_DIST = config.rpath \
+ ABOUT-NLS ACKNOWLEDGEMENTS AUTHORS CODING ChangeLog FAQ NEWS \
+ NP-VERSION-GEN REQUIREMENTS SUPPORT THANKS \
+ NPTest.pm pkg \
+ config_test/Makefile config_test/run_tests config_test/child_test.c \
+ tools/build_perl_modules \
+ tools/tinderbox_build
+
+ACLOCAL_AMFLAGS = -I gl/m4 -I m4
+
+localedir = $(datadir)/locale
+DEFS = -DLOCALEDIR=\"$(localedir)\"
+
+#
+# The ChangeLog file is auto-generated from the Git history. We let it depend
+# on NP-VERSION-GEN, as we bump our version number in that file.
+#
+ChangeLog: NP-VERSION-GEN
+ $(top_srcdir)/tools/generate-change-log > $@
+
+dist-hook:
+ $(MAKE) THANKS
+ echo ${VERSION} >$(distdir)/release
+
+install-root:
+ cd plugins-root && $(MAKE) $@
+
+test test-debug:
+ cd lib && $(MAKE) $@
+ if test "$(PERLMODS_DIR)" != ""; then cd && $(MAKE) $@; fi
+ cd plugins && $(MAKE) $@
+ cd plugins-scripts && $(MAKE) $@
+ cd plugins-root && $(MAKE) $@
+
+# Solaris pkgmk
+BUILDDIR = build-solaris
+PACKDIR = build-pkg
+PKGSCRIPT = pkg/solaris/solpkg
+
+solpkg:
+ if [ ! -d $(BUILDDIR) ] ; then mkdir $(BUILDDIR); fi
+ if [ ! -d $(PACKDIR) ] ; then mkdir $(PACKDIR); fi
+ $(MAKE) all
+ $(MAKE) DESTDIR=$$PWD/$(BUILDDIR) install
+ $(INSTALL) plugins-root/pst3 $(BUILDDIR)$(libexecdir)
+ $(INSTALL) pkg/solaris/pkginfo $(BUILDDIR)
+ $(INSTALL) pkg/solaris/preinstall $(BUILDDIR)
+ cd $(BUILDDIR) && $(PERL) ../$(PKGSCRIPT) ../$(PACKDIR)
+
+THANKS: THANKS.in
+ @echo "This software is brought to you by the Monitoring Plugins Development Team. However," > $@
+ @echo "there have been many contributors to this project. Everyone below has helped in " >> $@
+ @echo "raising bug reports, creating patches or contributing new plugins." >> $@
+ @echo "" >> $@
+ perl -e ' while (<>) { print STDERR "Duplicate: $$_",$$/ if ($$a{$$_}) ; $$a{$$_}++}; print sort by_last_field (keys %a); sub by_last_field { ($$a1) = $$a =~ /\s(\w+)$$/; ($$b1) = $$b =~ /\s(\w+)$$/; $$a1 cmp $$b1}' $? >> $@
+
+pkgclean:
+ rm -rf $(BUILDDIR) $(PACKDIR)
+