summaryrefslogtreecommitdiffstats
path: root/common/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'common/meson.build')
-rw-r--r--common/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/common/meson.build b/common/meson.build
index 4bca5ea..202880f 100644
--- a/common/meson.build
+++ b/common/meson.build
@@ -1,5 +1,8 @@
version_h = vcs_tag(
- command: ['git', 'describe', '--always', '--tags', '--dirty'],
+ command: ['git',
+ '--git-dir=' + join_paths(source_root, '.git'),
+ '--work-tree=' + source_root,
+ 'describe', '--always', '--tags', '--dirty'],
input: 'version.h.in',
output: 'version.h',
replace_string: '@VERSION@',