summaryrefslogtreecommitdiffstats
path: root/player/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--player/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/player/meson.build b/player/meson.build
new file mode 100644
index 0000000..dc334b8
--- /dev/null
+++ b/player/meson.build
@@ -0,0 +1,10 @@
+subdir('javascript')
+subdir('lua')
+
+# Meson doesn't allow having multiple build targets with the same name in the same file.
+# Just generate the com in here for windows builds.
+if win32 and get_option('cplayer')
+ wrapper_sources= '../osdep/win32-console-wrapper.c'
+ executable('mpv', wrapper_sources, c_args: '-municode', link_args: '-municode',
+ name_suffix: 'com', install: true)
+endif