summaryrefslogtreecommitdiffstats
path: root/player/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'player/meson.build')
-rw-r--r--player/meson.build7
1 files changed, 4 insertions, 3 deletions
diff --git a/player/meson.build b/player/meson.build
index dc334b8..be1e812 100644
--- a/player/meson.build
+++ b/player/meson.build
@@ -1,10 +1,11 @@
subdir('javascript')
subdir('lua')
-# Meson doesn't allow having multiple build targets with the same name in the same file.
-# Just generate the com in here for windows builds.
-if win32 and get_option('cplayer')
+# Older versions of meson don't allow multiple build targets with the same name in the same
+# file. Generate it here for compatibility reasons for windows.
+if win32 and get_option('cplayer') and meson.version().version_compare('< 1.3.0')
wrapper_sources= '../osdep/win32-console-wrapper.c'
executable('mpv', wrapper_sources, c_args: '-municode', link_args: '-municode',
name_suffix: 'com', install: true)
+ warning('mpv.com executable will be generated in the player subdirectory.')
endif