summaryrefslogtreecommitdiffstats
path: root/libnetdata/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 02:57:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 02:57:58 +0000
commitbe1c7e50e1e8809ea56f2c9d472eccd8ffd73a97 (patch)
tree9754ff1ca740f6346cf8483ec915d4054bc5da2d /libnetdata/Makefile.am
parentInitial commit. (diff)
downloadnetdata-be1c7e50e1e8809ea56f2c9d472eccd8ffd73a97.tar.xz
netdata-be1c7e50e1e8809ea56f2c9d472eccd8ffd73a97.zip
Adding upstream version 1.44.3.upstream/1.44.3upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'libnetdata/Makefile.am')
-rw-r--r--libnetdata/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/libnetdata/Makefile.am b/libnetdata/Makefile.am
new file mode 100644
index 00000000..333155aa
--- /dev/null
+++ b/libnetdata/Makefile.am
@@ -0,0 +1,45 @@
+# SPDX-License-Identifier: GPL-3.0-or-later
+
+AUTOMAKE_OPTIONS = subdir-objects
+MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
+
+SUBDIRS = \
+ adaptive_resortable_list \
+ aral \
+ avl \
+ buffer \
+ buffered_reader \
+ clocks \
+ completion \
+ config \
+ datetime \
+ dictionary \
+ ebpf \
+ eval \
+ facets \
+ functions_evloop \
+ json \
+ july \
+ health \
+ line_splitter \
+ locks \
+ log \
+ onewayalloc \
+ popen \
+ procfile \
+ simple_pattern \
+ socket \
+ statistical \
+ storage_number \
+ string \
+ threads \
+ url \
+ uuid \
+ worker_utilization \
+ tests \
+ $(NULL)
+
+dist_noinst_DATA = \
+ README.md \
+ gorilla/README.md \
+ $(NULL)