summaryrefslogtreecommitdiffstats
path: root/fluent-bit/lib/onigmo/README
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--fluent-bit/lib/onigmo/README252
-rw-r--r--fluent-bit/lib/onigmo/README.ja258
-rw-r--r--fluent-bit/lib/onigmo/README.md221
3 files changed, 731 insertions, 0 deletions
diff --git a/fluent-bit/lib/onigmo/README b/fluent-bit/lib/onigmo/README
new file mode 100644
index 00000000..8f468bb4
--- /dev/null
+++ b/fluent-bit/lib/onigmo/README
@@ -0,0 +1,252 @@
+README 2016/11/30
+
+Onigmo (Oniguruma-mod) -- (C) K.Takata <kentkt AT csc DOT jp>
+
+https://github.com/k-takata/Onigmo
+
+Onigmo is a regular expressions library forked from Oniguruma.
+It focuses to support new expressions like `\K`, `\R`, `(?(cond)yes|no)`
+and etc. which are supported in Perl 5.10+.
+
+Since Onigmo is used as the default regexp library of Ruby 2.0 or later,
+many patches are backported from Ruby 2.x.
+
+See also the Wiki page:
+https://github.com/k-takata/Onigmo/wiki
+
+
+Main New features:
+ Regular Expressions (depends on the syntax):
+ \K, \R, \X, (?(cond)yes|no)
+ (?adlu), \g{name}, \g{n}, (?&name), (?n), (?R), (?0)
+ (?P<name>...), (?P=name), (?P>name)
+
+ API:
+ onig_search_gpos (for Perl-compatible \G)
+
+ Encoding:
+ CP932, CP1250, CP1251, CP1252, CP1253, CP1254, CP1257
+
+ Syntax:
+ Python
+
+
+New Source Files:
+ enc/jis/props.h JIS character properties data.
+ enc/jis/props.kwd JIS character properties data.
+ enc/unicode/casefold.h Unicode case folding data.
+ enc/unicode/name2ctype.h Unicode properties data.
+ enc/windows_*.c CP* encoding
+
+ onigmo.py onigmo.dll/libonigmo.so loader.
+ testpy.py test program.
+
+ tool/download-ucd.sh downloads Unicode Character Database (UCD).
+ tool/case-folding.rb generates casefold.h from UCD.
+ tool/convert-jis-props.sh converts props.kwd to props.h.
+ tool/convert-name2ctype.sh converts name2ctype.kwd to name2ctypes.h.
+ tool/enc-unicode.rb generates name2ctype.kwd from UCD.
+
+ win32/Makefile.mingw Makefile for Win32 (MinGW)
+ win32/makedef.py creates onigmo.def.
+ win32/onigmo.rc resource file for onigmo.dll.
+
+
+ToDo:
+ * Reduce the size of Unicode Character Data.
+ * (?|...)
+ * Improve (?(cond)yes|no). (support look-ahead/behind assertions.)
+
+
+Oniguruma's README follows:
+======================================================================
+README 2007/05/31
+
+Oniguruma ---- (C) K.Kosako <sndgk393 AT ybb DOT ne DOT jp>
+
+http://www.geocities.jp/kosako3/oniguruma/
+
+Oniguruma is a regular expressions library.
+The characteristics of this library is that different character encoding
+for every regular expression object can be specified.
+
+Supported character encodings:
+
+ ASCII, UTF-8, UTF-16BE, UTF-16LE, UTF-32BE, UTF-32LE,
+ EUC-JP, EUC-TW, EUC-KR, EUC-CN,
+ Shift_JIS, Big5, GB18030, KOI8-R, CP1251,
+ ISO-8859-1, ISO-8859-2, ISO-8859-3, ISO-8859-4, ISO-8859-5,
+ ISO-8859-6, ISO-8859-7, ISO-8859-8, ISO-8859-9, ISO-8859-10,
+ ISO-8859-11, ISO-8859-13, ISO-8859-14, ISO-8859-15, ISO-8859-16
+
+* GB18030: contributed by KUBO Takehiro
+* CP1251: contributed by Byte
+------------------------------------------------------------
+
+License
+
+ BSD license.
+
+
+Install
+
+ Case 1: Unix and Cygwin platform
+
+ 1. ./autogen.sh (If `configure` doesn't exist.)
+ 2. ./configure
+ 3. make
+ 4. make install
+
+ * uninstall
+
+ make uninstall
+
+ * test (ASCII/EUC-JP)
+
+ make atest
+
+ * configuration check
+
+ onig-config --cflags
+ onig-config --libs
+ onig-config --prefix
+ onig-config --exec-prefix
+
+
+
+ Case 2: Win32 platform (VC++)
+
+ 1. copy win32\Makefile Makefile
+ 2. copy win32\config.h config.h
+ 3. nmake
+
+ onig_s.lib: static link library
+ onig.dll: dynamic link library
+
+ * test (ASCII/Shift_JIS)
+ 4. copy win32\testc.c testc.c
+ 5. nmake ctest
+
+
+
+Regular Expressions
+
+ See doc/RE (or doc/RE.ja for Japanese).
+
+
+Usage
+
+ Include oniguruma.h in your program. (Oniguruma API)
+ See doc/API for Oniguruma API.
+
+ If you want to disable UChar type (== unsigned char) definition
+ in oniguruma.h, define ONIG_ESCAPE_UCHAR_COLLISION and then
+ include oniguruma.h.
+
+ If you want to disable regex_t type definition in oniguruma.h,
+ define ONIG_ESCAPE_REGEX_T_COLLISION and then include oniguruma.h.
+
+ Example of the compiling/linking command line in Unix or Cygwin,
+ (prefix == /usr/local case)
+
+ cc sample.c -L/usr/local/lib -lonig
+
+
+ If you want to use static link library(onig_s.lib) in Win32,
+ add option -DONIG_EXTERN=extern to C compiler.
+
+
+
+Sample Programs
+
+ sample/simple.c example of the minimum (Oniguruma API)
+ sample/names.c example of the named group callback.
+ sample/encode.c example of some encodings.
+ sample/listcap.c example of the capture history.
+ sample/posix.c POSIX API sample.
+ sample/sql.c example of the variable meta characters.
+ (SQL-like pattern matching)
+
+Test Programs
+ sample/syntax.c Perl, Java and ASIS syntax test.
+ sample/crnl.c --enable-crnl-as-line-terminator test
+
+
+Source Files
+
+ oniguruma.h Oniguruma API header file. (public)
+ onig-config.in configuration check program template.
+
+ regenc.h character encodings framework header file.
+ regint.h internal definitions
+ regparse.h internal definitions for regparse.c and regcomp.c
+ regcomp.c compiling and optimization functions
+ regenc.c character encodings framework.
+ regerror.c error message function
+ regext.c extended API functions. (deluxe version API)
+ regexec.c search and match functions
+ regparse.c parsing functions.
+ regsyntax.c pattern syntax functions and built-in syntax definitions.
+ regtrav.c capture history tree data traverse functions.
+ regversion.c version info function.
+ st.h hash table functions header file
+ st.c hash table functions
+
+ oniggnu.h GNU regex API header file. (public)
+ reggnu.c GNU regex API functions
+
+ onigposix.h POSIX API header file. (public)
+ regposerr.c POSIX error message function.
+ regposix.c POSIX API functions.
+
+ enc/mktable.c character type table generator.
+ enc/ascii.c ASCII encoding.
+ enc/euc_jp.c EUC-JP encoding.
+ enc/euc_tw.c EUC-TW encoding.
+ enc/euc_kr.c EUC-KR, EUC-CN encoding.
+ enc/sjis.c Shift_JIS encoding.
+ enc/big5.c Big5 encoding.
+ enc/gb18030.c GB18030 encoding.
+ enc/koi8.c KOI8 encoding.
+ enc/koi8_r.c KOI8-R encoding.
+ enc/cp1251.c CP1251 encoding.
+ enc/iso8859_1.c ISO-8859-1 encoding. (Latin-1)
+ enc/iso8859_2.c ISO-8859-2 encoding. (Latin-2)
+ enc/iso8859_3.c ISO-8859-3 encoding. (Latin-3)
+ enc/iso8859_4.c ISO-8859-4 encoding. (Latin-4)
+ enc/iso8859_5.c ISO-8859-5 encoding. (Cyrillic)
+ enc/iso8859_6.c ISO-8859-6 encoding. (Arabic)
+ enc/iso8859_7.c ISO-8859-7 encoding. (Greek)
+ enc/iso8859_8.c ISO-8859-8 encoding. (Hebrew)
+ enc/iso8859_9.c ISO-8859-9 encoding. (Latin-5 or Turkish)
+ enc/iso8859_10.c ISO-8859-10 encoding. (Latin-6 or Nordic)
+ enc/iso8859_11.c ISO-8859-11 encoding. (Thai)
+ enc/iso8859_13.c ISO-8859-13 encoding. (Latin-7 or Baltic Rim)
+ enc/iso8859_14.c ISO-8859-14 encoding. (Latin-8 or Celtic)
+ enc/iso8859_15.c ISO-8859-15 encoding. (Latin-9 or West European with Euro)
+ enc/iso8859_16.c ISO-8859-16 encoding.
+ (Latin-10 or South-Eastern European with Euro)
+ enc/utf8.c UTF-8 encoding.
+ enc/utf16_be.c UTF-16BE encoding.
+ enc/utf16_le.c UTF-16LE encoding.
+ enc/utf32_be.c UTF-32BE encoding.
+ enc/utf32_le.c UTF-32LE encoding.
+ enc/unicode.c Unicode information data.
+
+ win32/Makefile Makefile for Win32 (VC++)
+ win32/config.h config.h for Win32
+
+
+
+ToDo
+
+ ? case fold flag: Katakana <-> Hiragana.
+ ? add ONIG_OPTION_NOTBOS/NOTEOS. (\A, \z, \Z)
+ ?? \X (== \PM\pM*)
+ ?? implement syntax behavior ONIG_SYN_CONTEXT_INDEP_ANCHORS.
+ ?? transmission stopper. (return ONIG_STOP from match_at())
+
+and I'm thankful to Akinori MUSHA.
+
+
+Mail Address: K.Kosako <sndgk393 AT ybb DOT ne DOT jp>
diff --git a/fluent-bit/lib/onigmo/README.ja b/fluent-bit/lib/onigmo/README.ja
new file mode 100644
index 00000000..3b50c27f
--- /dev/null
+++ b/fluent-bit/lib/onigmo/README.ja
@@ -0,0 +1,258 @@
+README.ja 2016/11/30
+
+鬼雲 (鬼車改) -- (C) K.Takata <kentkt AT csc DOT jp>
+
+https://github.com/k-takata/Onigmo
+
+鬼雲は、鬼車から派生した正規表現ライブラリである。
+Perl 5.10以降で導入された `\K`, `\R`, `(?(cond)yes|no)` などの新たな
+正規表現をサポートすることに注力している。
+
+鬼雲は、Ruby 2.0以降の標準の正規表現ライブラリであるため、多くのパッチが
+Ruby 2.xからバックポートされている。
+
+Wikiページも参照のこと。
+https://github.com/k-takata/Onigmo/wiki
+
+
+主な新機能:
+ 正規表現 (文法依存):
+ \K, \R, \X, (?(cond)yes|no)
+ (?adlu), \g{name}, \g{n}, (?&name), (?n), (?R), (?0)
+ (?P<name>...), (?P=name), (?P>name)
+
+ API:
+ onig_search_gpos (Perl互換の \G 用)
+
+ エンコーディング:
+ CP932, CP1250, CP1251, CP1252, CP1253, CP1254, CP1257
+
+ 文法:
+ Python
+
+
+新規ソースファイル:
+ enc/jis/props.h JIS 文字プロパティーデータ
+ enc/jis/props.kwd JIS 文字プロパティーデータ
+ enc/unicode/casefold.h Unicodeケースフォールドデータ
+ enc/unicode/name2ctype.h Unicodeプロパティデータ
+ enc/windows_*.c CP*エンコーディング
+
+ onigmo.py onigmo.dll/libonigmo.so ローダ
+ testpy.py テストプログラム
+
+ tool/download-ucd.sh Unicode Character Database (UCD)をダウンロード
+ tool/case-folding.rb UCDからcasefold.hを生成
+ tool/convert-jis-props.sh props.kwdをprops.hに変換
+ tool/convert-name2ctype.sh name2ctype.kwdをname2ctypes.hに変換
+ tool/enc-unicode.rb UCDからname2ctype.kwdを生成
+
+ win32/Makefile.mingw Win32用 Makefile (for MinGW)
+ win32/makedef.py onigmo.defを作成
+ win32/onigmo.rc onigmo.dll用リソースファイル
+
+
+ToDo:
+ * Unicode Character Data のサイズ削減。
+ * (?|...)
+ * (?(cond)yes|no) の改善。(先読み・戻り読みの対応)
+
+
+以下、鬼車の README.ja:
+======================================================================
+README.ja 2007/05/31
+
+鬼車 ---- (C) K.Kosako <sndgk393 AT ybb DOT ne DOT jp>
+
+http://www.geocities.jp/kosako3/oniguruma/
+
+鬼車は正規表現ライブラリである。
+このライブラリの特長は、それぞれの正規表現オブジェクトごとに
+文字エンコーディングを指定できることである。
+
+サポートしている文字エンコーディング:
+
+ ASCII, UTF-8, UTF-16BE, UTF-16LE, UTF-32BE, UTF-32LE,
+ EUC-JP, EUC-TW, EUC-KR, EUC-CN,
+ Shift_JIS, Big5, GB18030, KOI8-R, CP1251,
+ ISO-8859-1, ISO-8859-2, ISO-8859-3, ISO-8859-4, ISO-8859-5,
+ ISO-8859-6, ISO-8859-7, ISO-8859-8, ISO-8859-9, ISO-8859-10,
+ ISO-8859-11, ISO-8859-13, ISO-8859-14, ISO-8859-15, ISO-8859-16
+
+* GB18030: 久保健洋氏提供
+* CP1251: Byte氏提供
+------------------------------------------------------------
+
+ライセンス
+
+ BSDライセンスに従う。
+
+
+インストール
+
+ ケース1: UnixとCygwin環境
+
+ 1. .autogen.sh (`configure` が存在しなかった場合)
+ 2. ./configure
+ 3. make
+ 4. make install
+
+ アンインストール
+
+ make uninstall
+
+ 動作テスト (ASCII/EUC-JP)
+
+ make atest
+
+
+ 構成確認
+
+ onig-config --cflags
+ onig-config --libs
+ onig-config --prefix
+ onig-config --exec-prefix
+
+
+
+ ケース2: Win32(VC++)環境
+
+ 1. copy win32\Makefile Makefile
+ 2. copy win32\config.h config.h
+ 3. nmake
+
+ onig_s.lib: static link library
+ onig.dll: dynamic link library
+
+ * 動作テスト (ASCII/Shift_JIS)
+ 4. copy win32\testc.c testc.c
+ 5. nmake ctest
+
+
+
+正規表現
+
+ doc/RE.jaを参照
+
+
+使用方法
+
+ 使用するプログラムで、oniguruma.hをインクルードする(Oniguruma APIの場合)。
+ Oniguruma APIについては、doc/API.jaを参照。
+
+ oniguruma.hで定義されている型名UChar(== unsigned char)を無効にしたい場合
+ には、ONIG_ESCAPE_UCHAR_COLLISIONをdefineしてからoniguruma.hをインクルード
+ すること。このときにはUCharは定義されず、OnigUCharという名前の定義のみが
+ 有効になる。
+
+ oniguruma.hで定義されている型名regex_tを無効にしたい場合には、
+ ONIG_ESCAPE_REGEX_T_COLLISIONをdefineしてからoniguruma.hをインクルード
+ すること。このときにはregex_tは定義されず、OnigRegexType, OnigRegexという
+ 名前の定義のみが有効になる。
+
+ Unix/Cygwin上でコンパイル、リンクする場合の例:
+ (prefixが/usr/localのとき)
+ cc sample.c -L/usr/local/lib -lonig
+
+ GNU libtoolを使用しているので、プラットフォームが共有ライブラリをサポートして
+ いれば、使用できるようになっている。
+ 静的ライブラリと共有ライブラリのどちらを使用するかを指定する方法、実行時点での
+ 環境設定方法については、自分で調べて下さい。
+
+
+ Win32でスタティックリンクライブラリ(onig_s.lib)をリンクする場合には、
+ コンパイルするときに -DONIG_EXTERN=extern をコンパイル引数に追加すること。
+
+
+使用例プログラム
+
+ sample/simple.c 最小例 (Oniguruma API)
+ sample/names.c 名前付きグループコールバック使用例
+ sample/encode.c 幾つかの文字エンコーディング使用例
+ sample/listcap.c 捕獲履歴機能の使用例
+ sample/posix.c POSIX API使用例
+ sample/sql.c 可変メタ文字機能使用例 (SQL-like パターン)
+
+テストプログラム
+ sample/syntax.c Perl、Java、ASIS文法のテスト
+ sample/crnl.c --enable-crnl-as-line-terminator テスト
+
+
+ソースファイル
+
+ oniguruma.h 鬼車APIヘッダ (公開)
+ onig-config.in onig-configプログラム テンプレート
+
+ regenc.h 文字エンコーディング枠組みヘッダ
+ regint.h 内部宣言
+ regparse.h regparse.cとregcomp.cのための内部宣言
+ regcomp.c コンパイル、最適化関数
+ regenc.c 文字エンコーディング枠組み
+ regerror.c エラーメッセージ関数
+ regext.c 拡張API関数
+ regexec.c 検索、照合関数
+ regparse.c 正規表現パターン解析関数
+ regsyntax.c 正規表現パターン文法関数、組込み文法定義
+ regtrav.c 捕獲履歴木巡回関数
+ regversion.c 版情報関数
+ st.h ハッシュテーブル関数宣言
+ st.c ハッシュテーブル関数
+
+ oniggnu.h GNU regex APIヘッダ (公開)
+ reggnu.c GNU regex API関数
+
+ onigposix.h POSIX APIヘッダ (公開)
+ regposerr.c POSIX APIエラーメッセージ関数
+ regposix.c POSIX API関数
+
+ enc/mktable.c 文字タイプテーブル生成プログラム
+ enc/ascii.c ASCII エンコーディング
+ enc/euc_jp.c EUC-JP エンコーディング
+ enc/euc_tw.c EUC-TW エンコーディング
+ enc/euc_kr.c EUC-KR, EUC-CN エンコーディング
+ enc/sjis.c Shift_JIS エンコーディング
+ enc/big5.c Big5 エンコーディング
+ enc/gb18030.c GB18030 エンコーディング
+ enc/koi8.c KOI8 エンコーディング
+ enc/koi8_r.c KOI8-R エンコーディング
+ enc/cp1251.c CP1251 エンコーディング
+ enc/iso8859_1.c ISO-8859-1 (Latin-1)
+ enc/iso8859_2.c ISO-8859-2 (Latin-2)
+ enc/iso8859_3.c ISO-8859-3 (Latin-3)
+ enc/iso8859_4.c ISO-8859-4 (Latin-4)
+ enc/iso8859_5.c ISO-8859-5 (Cyrillic)
+ enc/iso8859_6.c ISO-8859-6 (Arabic)
+ enc/iso8859_7.c ISO-8859-7 (Greek)
+ enc/iso8859_8.c ISO-8859-8 (Hebrew)
+ enc/iso8859_9.c ISO-8859-9 (Latin-5 または Turkish)
+ enc/iso8859_10.c ISO-8859-10 (Latin-6 または Nordic)
+ enc/iso8859_11.c ISO-8859-11 (Thai)
+ enc/iso8859_13.c ISO-8859-13 (Latin-7 または Baltic Rim)
+ enc/iso8859_14.c ISO-8859-14 (Latin-8 または Celtic)
+ enc/iso8859_15.c ISO-8859-15 (Latin-9 または West European with Euro)
+ enc/iso8859_16.c ISO-8859-16
+ (Latin-10 または South-Eastern European with Euro)
+ enc/utf8.c UTF-8 エンコーディング
+ enc/utf16_be.c UTF-16BE エンコーディング
+ enc/utf16_le.c UTF-16LE エンコーディング
+ enc/utf32_be.c UTF-32BE エンコーディング
+ enc/utf32_le.c UTF-32LE エンコーディング
+ enc/unicode.c Unicode情報
+
+ win32/Makefile Win32用 Makefile (for VC++)
+ win32/config.h Win32用 config.h
+
+
+
+残件
+
+ ? case fold flag: Katakana <-> Hiragana
+ ? ONIG_OPTION_NOTBOS/NOTEOS追加 (\A, \z, \Z)
+ ?? \X (== \PM\pM*)
+ ?? 文法要素 ONIG_SYN_CONTEXT_INDEP_ANCHORSの実装
+ ?? 検索位置移動停止演算子 (match_at()からONIG_STOPを返す)
+
+and I'm thankful to Akinori MUSHA.
+
+
+アドレス: K.Kosako <sndgk393 AT ybb DOT ne DOT jp>
diff --git a/fluent-bit/lib/onigmo/README.md b/fluent-bit/lib/onigmo/README.md
new file mode 100644
index 00000000..ca29c0b7
--- /dev/null
+++ b/fluent-bit/lib/onigmo/README.md
@@ -0,0 +1,221 @@
+[![Build Status](https://travis-ci.org/k-takata/Onigmo.svg?branch=master)](https://travis-ci.org/k-takata/Onigmo)
+[![Build status](https://ci.appveyor.com/api/projects/status/kndb924qaw1hq72i/branch/master?svg=true)](https://ci.appveyor.com/project/k-takata/onigmo/branch/master)
+[![Coverage Status](https://coveralls.io/repos/k-takata/Onigmo/badge.svg?branch=master&service=github)](https://coveralls.io/github/k-takata/Onigmo?branch=master)
+[![Coverity Scan Build Status](https://scan.coverity.com/projects/2778/badge.svg)](https://scan.coverity.com/projects/k-takata-onigmo)
+[![Code Quality: Cpp](https://img.shields.io/lgtm/grade/cpp/g/k-takata/Onigmo.svg?logo=lgtm&logoWidth=18)](https://lgtm.com/projects/g/k-takata/Onigmo/context:cpp)
+[![Total Alerts](https://img.shields.io/lgtm/alerts/g/k-takata/Onigmo.svg?logo=lgtm&logoWidth=18)](https://lgtm.com/projects/g/k-takata/Onigmo/alerts)
+
+Onigmo (Oniguruma-mod)
+======================
+
+https://github.com/k-takata/Onigmo
+
+Onigmo is a regular expressions library forked from [Oniguruma](https://github.com/kkos/oniguruma).
+It focuses to support new expressions like `\K`, `\R`, `(?(cond)yes|no)`
+and etc. which are supported in Perl 5.10+.
+
+Since Onigmo is used as the default regexp library of Ruby 2.0 or later,
+many patches are backported from Ruby 2.x.
+
+See also the Wiki page:
+https://github.com/k-takata/Onigmo/wiki
+
+
+License
+-------
+
+ BSD license.
+
+
+Install
+-------
+
+### Case 1: Unix and Cygwin platform
+
+ 1. `./autogen.sh` (If `configure` doesn't exist.)
+ 2. `./configure`
+ 3. `make`
+ 4. `make install`
+
+ * test
+
+ make test
+
+ * uninstall
+
+ make uninstall
+
+ * configuration check
+
+ onigmo-config --cflags
+ onigmo-config --libs
+ onigmo-config --prefix
+ onigmo-config --exec-prefix
+
+
+### Case 2: Windows 64/32bit platform (Visual C++)
+
+ Execute `build_nmake.cmd`.
+ `build_x64` or `build_x86` will be used as a working/output directory.
+
+ onigmo_s.lib: static link library
+ onigmo.lib: import library for dynamic link
+ onigmo.dll: dynamic link library
+
+ * test (ASCII/Shift_JIS/EUC-JP/Unicode)
+
+ Execute `build_nmake.cmd test`.
+ Python (with the same bitness of Onigmo) is needed to run the tests.
+
+
+### Case 3: Windows 64/32bit platform (MinGW)
+
+ Execute `mingw32-make -f win32/Makefile.mingw`.
+ `build_x86-64`, `build_i686` and etc. will be used as a working/output
+ directory.
+
+ libonigmo.a: static link library
+ libonigmo.dll.a: import library for dynamic link
+ onigmo.dll: dynamic link library
+
+ * test (ASCII/Shift_JIS/EUC-JP/Unicode)
+
+ Execute `mingw32-make -f win32/Makefile.mingw test`.
+ Python (with the same bitness of Onigmo) is needed to run the tests.
+
+ * If you use MinGW on MSYS2, you can also use `./configure` and `make`
+ like Unix. In this case, DLL name will have API version number. E.g.:
+
+ libonigmo-6.dll
+
+
+Regular Expressions
+-------------------
+
+ See [doc/RE](doc/RE) or [doc/RE.ja](doc/RE.ja) for Japanese.
+
+
+Usage
+-----
+
+ Include onigmo.h in your program. (Onigmo API)
+ See [doc/API](doc/API) for Onigmo API.
+
+ If you want to disable `UChar` type (== `unsigned char`) definition
+ in onigmo.h, define `ONIG_ESCAPE_UCHAR_COLLISION` and then
+ include onigmo.h.
+
+ If you want to disable `regex_t` type definition in onigmo.h,
+ define `ONIG_ESCAPE_REGEX_T_COLLISION` and then include onigmo.h.
+
+ Example of the compiling/linking command line in Unix or Cygwin,
+ (prefix == /usr/local case)
+
+ cc sample.c -L/usr/local/lib -lonigmo
+
+
+ If you want to use static link library (onigmo_s.lib) in Win32,
+ add option `-DONIG_EXTERN=extern` to C compiler.
+
+
+
+Sample Programs
+---------------
+
+|File |Description |
+|:---------------------|:-----------------------------------------|
+|sample/simple.c |example of the minimum (Onigmo API) |
+|sample/names.c |example of the named group callback. |
+|sample/encode.c |example of some encodings. |
+|sample/listcap.c |example of the capture history. |
+|sample/posix.c |POSIX API sample. |
+|sample/sql.c |example of the variable meta characters. |
+
+
+Test Programs
+
+|File |Description |
+|:------------------|:--------------------------------------|
+|sample/syntax.c |Perl, Java and ASIS syntax test. |
+|sample/crnl.c |CRNL test |
+
+
+
+Source Files
+------------
+
+|File |Description |
+|:-------------------|:------------------------------------------------------|
+|onigmo.h |Onigmo API header file (public) |
+|onigmo-config.in |configuration check program template |
+|onigmo.py |Onigmo module for Python |
+|regenc.h |character encodings framework header file |
+|regint.h |internal definitions |
+|regparse.h |internal definitions for regparse.c and regcomp.c |
+|regcomp.c |compiling and optimization functions |
+|regenc.c |character encodings framework |
+|regerror.c |error message function |
+|regext.c |extended API functions (deluxe version API) |
+|regexec.c |search and match functions |
+|regparse.c |parsing functions. |
+|regsyntax.c |pattern syntax functions and built-in syntax definition|
+|regtrav.c |capture history tree data traverse functions |
+|regversion.c |version info function |
+|st.h |hash table functions header file |
+|st.c |hash table functions |
+|onigmognu.h |GNU regex API header file (public) |
+|reggnu.c |GNU regex API functions |
+|onigmoposix.h |POSIX API header file (public) |
+|regposerr.c |POSIX error message function |
+|regposix.c |POSIX API functions |
+|enc/mktable.c |character type table generator |
+|enc/ascii.c |ASCII-8BIT encoding |
+|enc/jis/ |JIS properties data |
+|enc/euc_jp.c |EUC-JP encoding |
+|enc/euc_tw.c |EUC-TW encoding |
+|enc/euc_kr.c |EUC-KR, EUC-CN encoding |
+|enc/shift_jis.c |Shift_JIS encoding |
+|enc/shift_jis.h |Common part of Shift_JIS and Windows-31J encoding |
+|enc/windows_31j.c |Windows-31J (CP932) encoding |
+|enc/big5.c |Big5 encoding |
+|enc/gb18030.c |GB18030 encoding |
+|enc/gbk.c |GBK encoding |
+|enc/koi8_r.c |KOI8-R encoding |
+|enc/koi8_u.c |KOI8-U encoding |
+|enc/iso_8859.h |common definition of ISO-8859 encoding |
+|enc/iso_8859_1.c |ISO-8859-1 (Latin-1) |
+|enc/iso_8859_2.c |ISO-8859-2 (Latin-2) |
+|enc/iso_8859_3.c |ISO-8859-3 (Latin-3) |
+|enc/iso_8859_4.c |ISO-8859-4 (Latin-4) |
+|enc/iso_8859_5.c |ISO-8859-5 (Cyrillic) |
+|enc/iso_8859_6.c |ISO-8859-6 (Arabic) |
+|enc/iso_8859_7.c |ISO-8859-7 (Greek) |
+|enc/iso_8859_8.c |ISO-8859-8 (Hebrew) |
+|enc/iso_8859_9.c |ISO-8859-9 (Latin-5 or Turkish) |
+|enc/iso_8859_10.c |ISO-8859-10 (Latin-6 or Nordic) |
+|enc/iso_8859_11.c |ISO-8859-11 (Thai) |
+|enc/iso_8859_13.c |ISO-8859-13 (Latin-7 or Baltic Rim) |
+|enc/iso_8859_14.c |ISO-8859-14 (Latin-8 or Celtic) |
+|enc/iso_8859_15.c |ISO-8859-15 (Latin-9 or West European with Euro) |
+|enc/iso_8859_16.c |ISO-8859-16 (Latin-10) |
+|enc/utf_8.c |UTF-8 encoding |
+|enc/utf_16be.c |UTF-16BE encoding |
+|enc/utf_16le.c |UTF-16LE encoding |
+|enc/utf_32be.c |UTF-32BE encoding |
+|enc/utf_32le.c |UTF-32LE encoding |
+|enc/unicode.c |common codes of Unicode encoding |
+|enc/unicode/ |Unicode case folding data and properties data |
+|enc/windows_1250.c |Windows-1250 (CP1250) encoding (Central/Eastern Europe)|
+|enc/windows_1251.c |Windows-1251 (CP1251) encoding (Cyrillic) |
+|enc/windows_1252.c |Windows-1252 (CP1252) encoding (Latin) |
+|enc/windows_1253.c |Windows-1253 (CP1253) encoding (Greek) |
+|enc/windows_1254.c |Windows-1254 (CP1254) encoding (Turkish) |
+|enc/windows_1257.c |Windows-1257 (CP1257) encoding (Baltic Rim) |
+|enc/cp949.c |CP949 encoding (only used in Ruby) |
+|enc/emacs_mule.c |Emacs internal encoding (only used in Ruby) |
+|enc/gb2312.c |GB2312 encoding (only used in Ruby) |
+|enc/us_ascii.c |US-ASCII encoding (only used in Ruby) |
+|win32/Makefile |Makefile for Win32 (VC++) |
+|win32/Makefile.mingw|Makefile for Win32 (MinGW) |
+|win32/config.h |config.h for Win32 |
+|win32/onigmo.rc |resource file for Win32 |