summaryrefslogtreecommitdiffstats
path: root/fluent-bit/tests/internal/aws
diff options
context:
space:
mode:
Diffstat (limited to 'fluent-bit/tests/internal/aws')
-rw-r--r--fluent-bit/tests/internal/aws/CMakeLists.txt7
-rw-r--r--fluent-bit/tests/internal/aws/placeholder.c11
2 files changed, 18 insertions, 0 deletions
diff --git a/fluent-bit/tests/internal/aws/CMakeLists.txt b/fluent-bit/tests/internal/aws/CMakeLists.txt
new file mode 100644
index 00000000..1685c0e2
--- /dev/null
+++ b/fluent-bit/tests/internal/aws/CMakeLists.txt
@@ -0,0 +1,7 @@
+# AWS unit tests
+set(UNIT_TESTS_FILES
+ placeholder.c
+ )
+
+# Prepare list of unit tests
+prepare_unit_tests(flb-it-aws_ "${UNIT_TESTS_FILES}")
diff --git a/fluent-bit/tests/internal/aws/placeholder.c b/fluent-bit/tests/internal/aws/placeholder.c
new file mode 100644
index 00000000..133c9a32
--- /dev/null
+++ b/fluent-bit/tests/internal/aws/placeholder.c
@@ -0,0 +1,11 @@
+#include "../flb_tests_internal.h"
+
+static void test_placeholder()
+{
+ return;
+}
+
+TEST_LIST = {
+ { "placeholder" , test_placeholder },
+ { 0 }
+};