summaryrefslogtreecommitdiffstats
path: root/web/server/h2o/libh2o/deps/picohttpparser/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--web/server/h2o/libh2o/deps/picohttpparser/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/web/server/h2o/libh2o/deps/picohttpparser/Makefile b/web/server/h2o/libh2o/deps/picohttpparser/Makefile
new file mode 100644
index 00000000..9e42298d
--- /dev/null
+++ b/web/server/h2o/libh2o/deps/picohttpparser/Makefile
@@ -0,0 +1,40 @@
+#
+# Copyright (c) 2009-2014 Kazuho Oku, Tokuhiro Matsuno, Daisuke Murase,
+# Shigeo Mitsunari
+#
+# The software is licensed under either the MIT License (below) or the Perl
+# license.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to
+# deal in the Software without restriction, including without limitation the
+# rights to use, copy, modify, merge, publish, distribute, sublicense, and/or
+# sell copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+# IN THE SOFTWARE.
+
+CC?=gcc
+PROVE?=prove
+
+all:
+
+test: test-bin
+ $(PROVE) -v ./test-bin
+
+test-bin: picohttpparser.c picotest/picotest.c test.c
+ $(CC) -Wall $(CFLAGS) $(LDFLAGS) -o $@ $^
+
+clean:
+ rm -f test-bin
+
+.PHONY: test