summaryrefslogtreecommitdiffstats
path: root/web/server/h2o/libh2o/deps/picotls/deps/cifra/extra_vecs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--web/server/h2o/libh2o/deps/picotls/deps/cifra/extra_vecs/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/web/server/h2o/libh2o/deps/picotls/deps/cifra/extra_vecs/Makefile b/web/server/h2o/libh2o/deps/picotls/deps/cifra/extra_vecs/Makefile
new file mode 100644
index 00000000..065721c2
--- /dev/null
+++ b/web/server/h2o/libh2o/deps/picotls/deps/cifra/extra_vecs/Makefile
@@ -0,0 +1,13 @@
+CFLAGS += -std=gnu99 -O0 -g -Wall -Werror
+
+all: run
+
+openssl-hash: openssl-hash.c
+ $(CC) $(CFLAGS) -o $@ $^ -lcrypto
+
+run: openssl-hash
+ ./openssl-hash
+ python python-hash.py
+
+clean:
+ rm -rf *.o openssl-hash